Issue 118267 - Undo after resize and connector line width change does not resize arrowheads
Undo after resize and connector line width change does not resize arrowheads
Status: RESOLVED FIXED
Product: Draw
Classification: Application
Component: formatting
OOo 3.3
Mac Mac OSX, 10.6
: P3 normal (vote)
: 4.0.0
Assigned To: Armin Le Grand
issues@graphics
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-09 01:43 UTC by bobbv
Modified: 2013-07-12 16:10 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Shows giant arrowheads after undone resize in Draw (9.37 KB, application/vnd.oasis.opendocument.graphics)
2011-07-09 01:43 UTC, bobbv
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description bobbv 2011-07-09 01:43:09 UTC
Created attachment 76678 [details]
Shows giant arrowheads after undone resize in Draw

When you resize a set of connected flowchart blocks, then change the size of the line width, then undo the resize, the size of the arrowheads doesn't change.

How to replicate:
Make two flowchart box
Connect them with a connector
Select all
Resize to be very small
Change the line width to be very large
Undo until the boxes are back to their normal size and location
Arrow heads will still be huge
Comment 1 Armin Le Grand 2011-11-02 13:18:22 UTC
ALG->bobbv: Thanks for the report. I checked with current OOo version and could reproduce this. Changing owner to me.
Comment 2 Oliver-Rainer Wittmann 2012-06-13 12:18:38 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.
Comment 3 Armin Le Grand 2012-07-25 16:16:05 UTC
ALG: Looks as if DrawViewShell::FuTemporary in SID_ATTR_LINE_WIDTH slot has no undo, needs to be added.
Comment 4 Armin Le Grand 2012-07-26 09:02:05 UTC
ALG: DrawViewShell::FuTemporary is a two-step process, it makes evtl. adaptions to objects (e.g. adapt arrow widths when line width is changed, but also switches on fill to white when shadow is switched on and object has no fill to make shadow visible). I will add undo actions for adaption of arrow width change caused by line width change, let's see if this works.
Comment 5 SVN Robot 2012-07-26 09:17:16 UTC
"alg" committed SVN revision 1365920 into trunk:
#118267# Add undo actions for adapted arrowhead sizes when linewidth is changed
Comment 6 Armin Le Grand 2012-07-26 09:17:42 UTC
ALG: Works as expected, checking in as revision 1365920.