Issue 118299 - writer crashes when printing a selected table
Summary: writer crashes when printing a selected table
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: printing (show other issues)
Version: OOo 3.3
Hardware: PC Windows 7
: P3 Normal (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-18 11:57 UTC by mutz
Modified: 2012-12-14 08:16 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
screenshot marked table (162.07 KB, image/jpeg)
2012-12-13 15:40 UTC, mutz
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mutz 2011-07-18 11:57:43 UTC
these crashes are reproduceable. Whole oppenOffice application crashes.
Comment 1 Oliver-Rainer Wittmann 2012-06-13 12:33:28 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.
Comment 2 eberlein 2012-12-13 13:13:08 UTC
fixed in 3.4.1?
Comment 3 Oliver-Rainer Wittmann 2012-12-13 13:25:04 UTC
(In reply to comment #2)
> fixed in 3.4.1?

I am not sure - it needs to be checked.

@mutz@cross-solution.de:
Can you please provide the steps to reproduce the crash? May be you have a document at hand with which it can be reproduced. Thanks in advance.
Comment 4 Oliver-Rainer Wittmann 2012-12-13 13:35:34 UTC
On my AOO 3.4.1 on Windows 7 I tried the following:
- new text document
- insert some paragraphs
- insert a table between the paragraphs
- select the table
- menu File - Print to print the selection
- confirming the print dialog to trigger the print
- chosen printer prints

Thus, I could not reproduce a crash by my simple try.
May be mutz@cross-solution.de has some further input.
Comment 5 mutz 2012-12-13 15:40:57 UTC
Created attachment 80023 [details]
screenshot marked table

same problem in 3.4.0.

steps to reproduce:

1. open new document
2. insert some text
3. insert a table
4. insert some text behind the table
5. mark the table (see screenshot1)
6. print the table (doesn't matter wether using ctrl-P or menu or which
printer chosen)
7. ooo-writer crashes (see screenshot2)

This has been reproduced on a totaly different (virtual) machine with
different printers than used when this incident was reported.

Attached:
Screenshots and the document

thanks for your help
Comment 6 Oliver-Rainer Wittmann 2012-12-13 16:37:42 UTC
@mutz@cross-solution.de: Thanks for the information.

I can confirm the crash using AOO 3.4 on my Windows 7.
AOO 3.4.1 does not crash on my Windows 7 using the same steps.

Thus, I can confirm that the issue is fixed in AOO 3.4.1

Can you give AOO 3.4.1 a try and check, if you can also confirm that the issue is fixed in AOO 3.4.1. Thanks in advance.
Comment 7 mutz 2012-12-13 17:36:50 UTC
after install of AOO 3.4.1 the marked table is printed without any problems.
For me this incident is solved.

Thanks a lot.
Comment 8 Oliver-Rainer Wittmann 2012-12-14 08:16:11 UTC
(In reply to comment #7)
> after install of AOO 3.4.1 the marked table is printed without any problems.
> For me this incident is solved.
> 
> Thanks a lot.

Thanks for the confirmation.

Closing issue