Issue 118442 - Installation Failing
Summary: Installation Failing
Status: UNCONFIRMED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 3.0
Hardware: PC Linux, all
: P3 Normal (vote)
Target Milestone: OOo 3.3
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needhelp
Depends on:
Blocks:
 
Reported: 2011-08-29 13:01 UTC by pkroetsch
Modified: 2014-02-11 12:11 UTC (History)
3 users (show)

See Also:
Issue Type: TASK
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description pkroetsch 2011-08-29 13:01:41 UTC
I am trying to install OO on my RHEL 6 64 bit os. But I am getting an installation failed message. Here are the details.

I am not sure what the issue is...

This is the package i am tring to install

OOo_3.3.0_Linux_x86-64_install-rpm-wJRE_en-US.tar.gz

I run:

tar zxf OOo_3.3.0_Linux_x86-64_install-rpm-wJRE_en-US.tar.gz

then go into this directory

cd OOO330_m20_native_packed-1_en-US.9567

then i run ./setup 



Product: OpenOffice.org 3.3 Location: /home/btrontvet Operating system: Linux Installation type: User installation ------------------------------------------------------------- Adding required package: Adding required package: openoffice.org3-3.3.0-9567.x86_64.rpm Adding required package: ooobasis3.3-core04-3.3.0-9567.x86_64.rpm Packages path: /home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/  -------------------------------------------------------------  ************************************* Checking change installation *************************************  rpm --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE --query -a Returns: 0   ************************************* Analyzing system database *************************************   ************************************* Installation *************************************  Package Name: ooobasis3.3-core04-3.3.0-9567.x86_64.rpm rpm --upgrade --ignoresize -vh --relocate /opt=/home/btrontvet//opt --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE "/home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/ooobasis3.3-core04-3.3.0-9567.x86_64.rpm" Returns: 1 Error during installation  error: Failed dependencies: libfreetype.so.6()(64bit) is needed by ooobasis3.3-core04-3.3.0-9567.x86_64 Package Name: openoffice.org3-3.3.0-9567.x86_64.rpm rpm --upgrade --ignoresize -vh --relocate /opt=/home/btrontvet//opt --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE "/home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/openoffice.org3-3.3.0-9567.x86_64.rpm" Returns: 1 Error during installation  error: Failed dependencies: ooobasis3.3-core04 is needed by openoffice.org3-3.3.0-9567.x86_64 Package Name: ooobasis3.3-gnome-integration-3.3.0-9567.x86_64.rpm rpm --upgrade --ignoresize -vh --relocate /opt=/home/btrontvet//opt --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE "/home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/ooobasis3.3-gnome-integration-3.3.0-9567.x86_64.rpm" Returns: 1 Error during installation  error: Failed dependencies: libgnomevfs-2.so.0()(64bit) is needed by ooobasis3.3-gnome-integration-3.3.0-9567.x86_64 libgconf-2.so.4()(64bit) is needed by ooobasis3.3-gnome-integration-3.3.0-9567.x86_64 Package Name: openoffice.org3-writer-3.3.0-9567.x86_64.rpm rpm --upgrade --ignoresize -vh --relocate /opt=/home/btrontvet//opt --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE "/home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/openoffice.org3-writer-3.3.0-9567.x86_64.rpm" Returns: 1 Error during installation  error: Failed dependencies: openoffice.org3 is needed by openoffice.org3-writer-3.3.0-9567.x86_64 Package Name: openoffice.org3-calc-3.3.0-9567.x86_64.rpm rpm --upgrade --ignoresize -vh --relocate /opt=/home/btrontvet//opt --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE "/home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/openoffice.org3-calc-3.3.0-9567.x86_64.rpm" Returns: 1 Error during installation  error: Failed dependencies: openoffice.org3 is needed by openoffice.org3-calc-3.3.0-9567.x86_64 Package Name: openoffice.org3-draw-3.3.0-9567.x86_64.rpm rpm --upgrade --ignoresize -vh --relocate /opt=/home/btrontvet//opt --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE "/home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/openoffice.org3-draw-3.3.0-9567.x86_64.rpm" Returns: 1 Error during installation  error: Failed dependencies: openoffice.org3 is needed by openoffice.org3-draw-3.3.0-9567.x86_64 Package Name: openoffice.org3-impress-3.3.0-9567.x86_64.rpm rpm --upgrade --ignoresize -vh --relocate /opt=/home/btrontvet//opt --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE "/home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/openoffice.org3-impress-3.3.0-9567.x86_64.rpm" Returns: 1 Error during installation  error: Failed dependencies: openoffice.org3 is needed by openoffice.org3-impress-3.3.0-9567.x86_64 Package Name: openoffice.org3-base-3.3.0-9567.x86_64.rpm rpm --upgrade --ignoresize -vh --relocate /opt=/home/btrontvet//opt --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE "/home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/openoffice.org3-base-3.3.0-9567.x86_64.rpm" Returns: 1 Error during installation  error: Failed dependencies: openoffice.org3 is needed by openoffice.org3-base-3.3.0-9567.x86_64 Package Name: openoffice.org3-math-3.3.0-9567.x86_64.rpm rpm --upgrade --ignoresize -vh --relocate /opt=/home/btrontvet//opt --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE "/home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/openoffice.org3-math-3.3.0-9567.x86_64.rpm" Returns: 1 Error during installation  error: Failed dependencies: openoffice.org3 is needed by openoffice.org3-math-3.3.0-9567.x86_64 Package Name: openoffice.org3-en-US-3.3.0-9567.x86_64.rpm rpm --upgrade --ignoresize -vh --relocate /opt=/home/btrontvet//opt --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE "/home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/openoffice.org3-en-US-3.3.0-9567.x86_64.rpm" Returns: 1 Error during installation  error: Failed dependencies: openoffice.org3 is needed by openoffice.org3-en-US-3.3.0-9567.x86_64 Package Name: openoffice.org3-dict-en-3.3.0-9567.x86_64.rpm rpm --upgrade --ignoresize -vh --relocate /opt=/home/btrontvet//opt --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE "/home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/openoffice.org3-dict-en-3.3.0-9567.x86_64.rpm" Returns: 1 Error during installation  error: Failed dependencies: ooobasis3.3-core04 is needed by openoffice.org3-dict-en-3.3.0-9567.x86_64 openoffice.org3 is needed by openoffice.org3-dict-en-3.3.0-9567.x86_64 Package Name: openoffice.org3-dict-fr-3.3.0-9567.x86_64.rpm rpm --upgrade --ignoresize -vh --relocate /opt=/home/btrontvet//opt --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE "/home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/openoffice.org3-dict-fr-3.3.0-9567.x86_64.rpm" Returns: 1 Error during installation  error: Failed dependencies: ooobasis3.3-core04 is needed by openoffice.org3-dict-fr-3.3.0-9567.x86_64 openoffice.org3 is needed by openoffice.org3-dict-fr-3.3.0-9567.x86_64 Package Name: openoffice.org3-dict-es-3.3.0-9567.x86_64.rpm rpm --upgrade --ignoresize -vh --relocate /opt=/home/btrontvet//opt --dbpath /home/btrontvet/.RPM_OFFICE_DATABASE "/home/btrontvet/Documents/OOO330_m20_native_packed-1_en-US.9567/RPMS/openoffice.org3-dict-es-3.3.0-9567.x86_64.rpm" Returns: 1 Error during installation  error: Failed dependencies: ooobasis3.3-core04 is needed by openoffice.org3-dict-es-3.3.0-9567.x86_64 openoffice.org3 is needed by openoffice.org3-dict-es-3.3.0-9567.x86_64
Comment 1 Patrick Daly 2011-10-24 22:35:54 UTC
I get the same behavior, libfreetype.so.6 not seen, on RHEL 5.3 on a x86_64.
I've installed various versions of OO before and this 
is the first time I've run into this.

I'm likewise using non-root install to a "relocated" install area
as we don't get to to root installs here.  :-( 

I tried setting LD_LIBRARY_PATH to point to my relocated install area
(with nothing of interest to OO, I believe) but more importantly
to the /usr/lib64 directory with the libfreetype.so.6 
that "setup" cannot see:

 # echo $LD_LIBRARY_PATH  
/users/pd06/local/x86_64/lib:/usr/lib64


# ls -l /usr/lib64/libfreetype.so*
lrwxrwxrwx 1 root root     21 Aug 17  2009 /usr/lib64/libfreetype.so -> libfreetype.so.6.3.10
lrwxrwxrwx 1 root root     21 Aug 17  2009 /usr/lib64/libfreetype.so.6 -> libfreetype.so.6.3.10
-rwxr-xr-x 1 root root 543824 Jun 17  2008 /usr/lib64/libfreetype.so.6.3.10

I tried also setting PKG_CONFIG_PATH to see if that would help
"setup" find libfreetype.so.6, but that didn't help.

I'm wondering if the "setup" method of install using the option
--dbpath /users/pd06/local/x86_64/.RPM_OFFICE_DATABASE causes it
to ignore the system install of libfreetype and look only in the
.RPM_OFFICE_DATABASE (I expected it to look in both places).

To get around the libfreetype.so.6 missing, I decided to try rpm installing
that rpm that wants it, using the relocate options the setup error "details"
reported but with "--nodeps" (ignore dependencies) added:

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
#  rpm --upgrade --ignoresize -vh --relocate /opt=/users/pd06/local/x86_64/opt --dbpath /users/pd06/local/x86_64/.RPM_OFFICE_DATABASE RPMS/ooobasis3.3-core04-3.3.0-9567.x86_64.rpm --nodeps
Preparing...                ########################################### [100%]
   1:ooobasis3.3-core04     ########################################### [100%]
 1004 # ./setup 
Checksumming...
Extracting ...
97072 blocks
Done.
Using /var/tmp/install_20063/usr/java/jre1.6.0_22/bin/java
java version "1.6.0_22"
Java(TM) SE Runtime Environment (build 1.6.0_22-b04)
Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03, mixed mode)

Running installer
/var/tmp/install_20063/usr/java/jre1.6.0_22/bin/java -DHOME=/users/pd06 -DJRE_FILE=jre-6u22-linux-amd64.rpm -jar JavaSetup.jar
System locale: en_US
User privileges
OS: Linux
Mode: installation
Path to packages: /users/pd06/local/x86_64/opt/OOO330_m20_native_packed-1_en-US.9567/RPMS/
Jar file: /users/pd06/local/x86_64/opt/OOO330_m20_native_packed-1_en-US.9567/JavaSetup.jar
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

 
The above let a subsequent run of "setup" proceed, but it also said
there was an installation error. Yet when looking at the "details"
all the rpm's showed successful install (I could see no error messages).

Open Office appears to run now although I haven't used it extensively
since this install (yet).
Comment 2 Oliver-Rainer Wittmann 2012-06-13 12:17:23 UTC
getting rid of value "enhancement" for field "severity".
For enhancement the field "issue type" shall be used.