Issue 118456 - Text is not displayed in slideshow when still in edit mode
Summary: Text is not displayed in slideshow when still in edit mode
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: 3.4.0 Beta (OOo)
Hardware: PC Windows 7
: P5 (lowest) Major (vote)
Target Milestone: ---
Assignee: Armin Le Grand
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-22 11:56 UTC by Armin Le Grand
Modified: 2012-09-14 09:22 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
patch to solve the missing text problem (870 bytes, patch)
2011-09-22 13:23 UTC, Armin Le Grand
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Armin Le Grand 2011-09-22 11:56:37 UTC
ALG: When editing text in Impress and pressing (F5) for Slideshow, that text is not shown there. To check:

1, new impress
2, type text (e.g. in Title)
3, Press (F5) (without leaving TextEdit mode)
-> Slide does not show the text
Comment 1 Armin Le Grand 2011-09-22 11:57:30 UTC
ALG: There is a EndTextEdit call missing when SlideShow gets started. Taking a look...
Comment 2 Armin Le Grand 2011-09-22 13:23:10 UTC
Created attachment 76798 [details]
patch to solve the missing text problem

ALG: Best place to fix is directly in SlideShow startup, thus all users which potentially start a SlideShow will do the right thing. Tested, works well.
Comment 3 hdu@apache.org 2011-09-22 13:40:17 UTC
Thanks! Applied as http://svn.apache.org/viewvc?rev=1174130&view=rev
Comment 4 Li Feng Wang 2012-09-14 09:21:57 UTC
can't reproduce on AOO trunk r1378003.