Issue 118587 - IP clearance, remove libwpd
Summary: IP clearance, remove libwpd
Status: CLOSED FIXED
Alias: None
Product: wp
Classification: Code
Component: code (show other issues)
Version: version58
Hardware: PC All
: P5 (lowest) Critical
Target Milestone: ---
Assignee: jsc
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 118919 118566
  Show dependency tree
 
Reported: 2011-11-09 11:53 UTC by jsc
Modified: 2016-04-09 10:44 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
patch to remove LGPL libwpd (40.79 KB, patch)
2011-11-14 13:40 UTC, jsc
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description jsc 2011-11-09 11:53:49 UTC
the used libwpd is under LGPL and we can't use it anymore.

This issue should cover the removal of the libwpd library and disabling the built of the depending filter. The filter can be still built with a system
version of libwpd but the default is to disable it.
Comment 1 jsc 2011-11-14 13:40:09 UTC
Created attachment 77013 [details]
patch to remove LGPL libwpd
Comment 2 jsc 2011-11-14 13:42:30 UTC
solved, http://svn.apache.org/viewvc?rev=1201697&view=rev
Comment 3 Pedro Giffuni 2011-11-15 22:49:52 UTC
(In reply to comment #2)
> solved, http://svn.apache.org/viewvc?rev=1201697&view=rev

I have been using  --with-system-libwpd

but this commit broke my configuration:

...
checking which libwpd to use... external
checking for LIBWPD... no
configure: error: Package requirements (libwpd-0.8 ) were not met:

No package 'libwpd-0.8' found

---

I am using libwpd-0.9.9, because libwpd 0.8 is not available
in my system anymore.

Also note that this is not necessarily bad, according to
the homepage:

http://libwpd.sourceforge.net/news.html

"libwpd 0.9.0 is not backward compatible with libwpd 0.8.14."
Comment 4 jsc 2011-11-18 14:48:10 UTC
i will not take care of any update to a newer libwpd version here. This can be addressed in a separate issue
Comment 5 Marcus 2016-04-09 09:43:29 UTC
In the meantime it was decided to remove the complete Word Perfect filters (see issue 126369).
Comment 6 Andrea Pescetti 2016-04-09 10:44:24 UTC
The information Marcus added is correct, but the link is not. Issue 126369 concerns the HWP removal, which is unrelated to Wordperfect filters. Anyway the current issue can indeed be considered closed.