Issue 118675 - Extension manager: Crash when checking for updates
Summary: Extension manager: Crash when checking for updates
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 3.4.0 Beta (OOo)
Hardware: All All
: P2 Critical (vote)
Target Milestone: ---
Assignee: hdu@apache.org
QA Contact:
URL:
Keywords:
Depends on: 118569 118584
Blocks:
  Show dependency tree
 
Reported: 2011-12-09 12:32 UTC by hdu@apache.org
Modified: 2012-01-27 09:05 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description hdu@apache.org 2011-12-09 12:32:05 UTC
For the last three weeks the neon library has been disabled or removed. Since then the extension manager always crashes when the "Check for Updates" button is pressed or clicked.
To reproduce do click
   Tools -> ExtensionManager -> CheckForUpdates

The problem happens in all builds based on the SVN trunk >= r1201696 and still happens with the latest revision (as of 1211941).
Comment 1 hdu@apache.org 2011-12-09 13:08:54 UTC
The crash is an unhandled cssu::RuntimeException with
  "unsatisfied query for interface of type com.sun.star.ucb.XCommandProcessor!"
thrown because of the implicit conversion in line 499 of
  extensions/source/update/feed/updatefeed.cxx
in the UpdateInformationProvider::load() method. With neon not being fully replaced yet the XContentProvider fails to provide an appropriate object with the XCommandProcessor interface.
Comment 2 hdu@apache.org 2011-12-15 15:03:40 UTC
Solved in revision 1214797.
Comment 3 hdu@apache.org 2012-01-27 09:05:03 UTC
Closing resolved issue.