Issue 118879 - [From Symphony] Presentation crashed if exit screen show
Summary: [From Symphony] Presentation crashed if exit screen show
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: 3.4.0 Beta (OOo)
Hardware: All All
: P3 Critical (vote)
Target Milestone: 3.4.1
Assignee: Andre
QA Contact:
URL:
Keywords:
: 119367 120070 120087 (view as issue list)
Depends on:
Blocks:
 
Reported: 2012-02-07 03:21 UTC by Yan Ji
Modified: 2013-05-31 17:46 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 3.4.1_release_blocker+


Attachments
Simple file that crashes if ESC is pressed while transition is in progress during slide show (9.69 KB, application/vnd.oasis.opendocument.presentation)
2012-05-12 14:33 UTC, Alan Mandel
no flags Details
Prevent destruction (but not disposing) of SlideshowImpl inside PostYieldListener (936 bytes, patch)
2012-05-23 12:05 UTC, Andre
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-02-07 03:21:37 UTC
1.Open the sample file.
2.Press F5 to play screenshow.
3.Keep turning to next page.
4.Press "ESC" to exist screen show.

Defect: Sometimes Impress will crash
Comment 1 hdu@apache.org 2012-02-07 13:39:54 UTC
Please don't forget to attach the sample file you mentioned.
Comment 2 Yan Ji 2012-02-08 00:33:34 UTC
Sample file is large than 4.5 MB, cannot attached to bugzilla.
Comment 3 Alan Mandel 2012-05-12 14:33:13 UTC
Created attachment 77535 [details]
Simple file that crashes if ESC is pressed while transition is in progress during slide show

Here is a file that can replicate the problem in 3.4.

Open the file
Start a slide show
Press ESC before the rectangle animation fully finishes
Impress will crash

If you wait for the rectangle animation to finish, though, hitting ESC works properly
Comment 4 r4zoli 2012-05-16 16:28:32 UTC
*** Issue 119367 has been marked as a duplicate of this issue. ***
Comment 5 r4zoli 2012-05-16 16:32:23 UTC
Open any presentation with animation. Not depending on file format. Same crash happens with ppt or odp file.

Or open presentation without animation, add any animation to objects.  

Run slide show, quit form slide show mode with pressing ESC AOO crash, in all case and file recovery starts.

See QA mailing list: http://mail-archives.apache.org/mod_mbox/incubator-ooo-qa/201205.mbox/browser

Not happens in earlier versions, OOo 3.3., regression.

I suggest it as  a release blocker for 3.4.1
Comment 6 Andre 2012-05-22 16:04:27 UTC
A first analysis revealed that crash to happen in SlideshowImpl::updateSlideShow() when called from the PostYieldListener (all in main/sd/source/ui/slideshow/slideshowimpl.cxx).  The PostYieldListener is properly removed when the slide show is ended but still called after the SlideshowImpl object is destroyed.
Comment 7 Andre 2012-05-23 12:03:31 UTC
The root cause is the call to Application::Reschedule() inside PostYieldListener.  The calling SlideshowImpl object is destroyed in this call which then returns to a dead object.

Fixed by creating a local rtl::Reference to this and thereby by postponing the destruction to the end of PostYieldListener().  That allows a guard of the call to updateSlideShow() against being disposed.

Revision is 1341841.
Comment 8 Andre 2012-05-23 12:05:35 UTC
Created attachment 77583 [details]
Prevent destruction (but not disposing) of SlideshowImpl inside PostYieldListener

Here is the patch for easier integration into other branches.
Comment 9 Andre 2012-05-23 14:24:20 UTC
Taking over ownership.
Comment 10 jsc 2012-05-31 07:25:18 UTC
set release blocker flag for 3.4.1
Comment 11 Oliver-Rainer Wittmann 2012-06-06 10:45:02 UTC
merged fix from trunk into branch AOO34, revision 1346816
Comment 12 liuping 2012-06-21 07:59:10 UTC
Confirm fixing the bug on ver 1351249 in Win7 ,pass
Comment 13 rousu 2012-06-24 06:04:15 UTC
Comment on attachment 77535 [details]
Simple file that crashes if ESC is pressed while transition is in progress during slide show

The download seems to be an example file to show the phenomenon, it is not the bug report as far as I can tell.
Comment 14 Ariel Constenla-Haile 2012-06-25 23:30:01 UTC
*** Issue 120087 has been marked as a duplicate of this issue. ***
Comment 15 Yurggent Alfredo Chable Torrez 2013-05-31 17:46:16 UTC
*** Issue 120070 has been marked as a duplicate of this issue. ***