Issue 118909 - ElementNames of css.ui.UICategoryDescription service has some empty strings
Summary: ElementNames of css.ui.UICategoryDescription service has some empty strings
Status: RESOLVED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 3.4.0 Beta (OOo)
Hardware: PC All
: P3 Minor (vote)
Target Milestone: 4.1.0
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-14 14:36 UTC by hanya
Modified: 2014-01-08 08:42 UTC (History)
1 user (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Patch to fix this problem, increment n in the while loop (538 bytes, patch)
2012-10-02 13:06 UTC, hanya
hanya.runo: review? (hanya.runo)
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description hanya 2012-02-14 14:36:30 UTC
getElementNames method of css.ui.UICategoryDescription returns list of module names but it returns some empty strings in it.

Sub UICategoryDescription
  cd = CreateUnoService("com.sun.star.ui.UICategoryDescription")
  names = cd.getElementNames()
  txt = ""
  for i = 0 to ubound(names) step 1
    txt =  txt & "'" & names(i) & "'" & chr(10)
  next
  msgbox txt
End Sub

com.sun.star.frame.UICommandDescription has the same problem.
Comment 1 hanya 2012-10-02 13:06:21 UTC
Created attachment 79708 [details]
Patch to fix this problem, increment n in the while loop

This problem is happen because n is not incremented in the while loop to fill sequence with elements.
The above basic code can be used to verify this patch.
Comment 2 Rob Weir 2013-03-11 15:05:09 UTC
I'm adding this comment to all open issues with Issue Type == PATCH.  We have 220 such issues, many of them quite old.  I apologize for that.  

We need your help in prioritizing which patches should be integrated into our next release, Apache OpenOffice 4.0.

If you have submitted a patch and think it is applicable for AOO 4.0, please respond with a comment to let us know.

On the other hand, if the patch is no longer relevant, please let us know that as well.

If you have any general questions or want to discuss this further, please send a note to our dev mailing list:  dev@openoffice.apache.org

Thanks!

-Rob
Comment 3 SVN Robot 2014-01-08 08:40:09 UTC
"hanya" committed SVN revision 1556463 into trunk:
#i118909# fix empty elements of return value in UICategoryDescription::getEle...
Comment 4 hanya 2014-01-08 08:42:17 UTC
Fixed in trunk. The fix can be confirmed with the small macro written in the report description.