Issue 119036 - WebDAV https has problems to browse a folder
Summary: WebDAV https has problems to browse a folder
Status: CLOSED FIXED
Alias: None
Product: ucb
Classification: Code
Component: code (show other issues)
Version: AOO340-dev
Hardware: PC Mac OS X 10
: P3 Critical (vote)
Target Milestone: ---
Assignee: Oliver-Rainer Wittmann
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-08 10:18 UTC by jsc
Modified: 2016-04-09 10:12 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 3.4_release_blocker+


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jsc 2012-03-08 10:18:59 UTC
The reimplemented WebDAV UCP has problems to browse a directory in the folder. Instead the html view of the folder is loaded.

Loading full qualified document Urls works as expected.

Normal http access works as well.

This is a regression to 3.3 and I think a show stopper
Comment 1 Oliver-Rainer Wittmann 2012-03-12 08:21:31 UTC
root cause found:
Depending on using transfer-encoding "chunked" or not the server may be replies with HTTP status code 413. This causes the processing to be canceled.

solution:
- Use "chunked" transfer-encoding on HTTPS connection.
- Improve handling of HTTP status code 413

I am expecting to have the fix ready today.
Comment 2 Oliver-Rainer Wittmann 2012-03-12 16:07:24 UTC
fixed - changed files:
ucb/source/ucp/webdav/DAVResourceAccess.cxx
ucb/source/ucp/webdav/SerfCopyReqProcImpl.cxx
ucb/source/ucp/webdav/SerfCopyReqProcImpl.hxx
ucb/source/ucp/webdav/SerfDeleteReqProcImpl.cxx
ucb/source/ucp/webdav/SerfDeleteReqProcImpl.hxx
ucb/source/ucp/webdav/SerfGetReqProcImpl.cxx
ucb/source/ucp/webdav/SerfGetReqProcImpl.hxx
ucb/source/ucp/webdav/SerfHeadReqProcImpl.cxx
ucb/source/ucp/webdav/SerfHeadReqProcImpl.hxx
ucb/source/ucp/webdav/SerfMkColReqProcImpl.cxx
ucb/source/ucp/webdav/SerfMkColReqProcImpl.hxx
ucb/source/ucp/webdav/SerfMoveReqProcImpl.cxx
ucb/source/ucp/webdav/SerfMoveReqProcImpl.hxx
ucb/source/ucp/webdav/SerfPostReqProcImpl.cxx
ucb/source/ucp/webdav/SerfPostReqProcImpl.hxx
ucb/source/ucp/webdav/SerfPropFindReqProcImpl.cxx
ucb/source/ucp/webdav/SerfPropFindReqProcImpl.hxx
ucb/source/ucp/webdav/SerfPropPatchReqProcImpl.cxx
ucb/source/ucp/webdav/SerfPropPatchReqProcImpl.hxx
ucb/source/ucp/webdav/SerfPutReqProcImpl.cxx
ucb/source/ucp/webdav/SerfPutReqProcImpl.hxx
ucb/source/ucp/webdav/SerfRequestProcessor.cxx
ucb/source/ucp/webdav/SerfRequestProcessor.hxx
ucb/source/ucp/webdav/SerfRequestProcessorImpl.cxx
ucb/source/ucp/webdav/SerfRequestProcessorImpl.hxx
ucb/source/ucp/webdav/SerfSession.cxx
ucb/source/ucp/webdav/SerfSession.hxx
uui/source/iahndl-ssl.cxx
revision 1299727
Comment 3 Marcus 2016-04-09 10:12:44 UTC
fixed in 4.0.0