Issue 119048 - AOO340: Migrate or cleanup extensions from OOo330
Summary: AOO340: Migrate or cleanup extensions from OOo330
Status: CLOSED FIXED
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: 3.4.0-dev
Hardware: All All
: P3 Critical (vote)
Target Milestone: 3.4.0
Assignee: hdu@apache.org
QA Contact:
URL:
Keywords:
: 119049 (view as issue list)
Depends on:
Blocks: 121721
  Show dependency tree
 
Reported: 2012-03-12 08:04 UTC by hdu@apache.org
Modified: 2013-02-05 09:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 3.4_release_blocker+


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description hdu@apache.org 2012-03-12 08:04:59 UTC
When OOo depended on BerkeleyDB for managing its extensions a change of this library to a different version caused some problems like issue 104465 or 100916. With bdb being replaced due to 118662 these problems will go away for good. For this step we either need to migrate the extensions or clean the registry if we want to avoid inconsistencies.
Comment 1 hdu@apache.org 2012-03-12 08:23:48 UTC
*** Issue 119049 has been marked as a duplicate of this issue. ***
Comment 2 Oliver Brinzing 2012-03-12 10:41:36 UTC
.
Comment 3 hdu@apache.org 2012-03-15 13:55:47 UTC
I added a heuristic to migrate OOo3's BDB files used for managing extensions to the new format. It shows that these non-encrypted BDB Hash v9 style files are easy enough to parse.
Comment 4 hdu@apache.org 2013-02-05 09:31:45 UTC
Closing the fixed issue.