Issue 119103 - Grammar and Spell Check fails when Right-Click Create
Summary: Grammar and Spell Check fails when Right-Click Create
Status: CLOSED DUPLICATE of issue 120610
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 3.3
Hardware: Other Windows 7
: P3 Major with 1 vote (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact: saisyamala
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2012-03-21 01:13 UTC by Hankorama
Modified: 2013-09-24 15:09 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Spelling and Grammar not working : sample (10.55 KB, application/vnd.oasis.opendocument.text)
2012-03-21 01:13 UTC, Hankorama
no flags Details
Non-working test file (10.21 KB, application/vnd.oasis.opendocument.text)
2012-10-01 06:09 UTC, jentzmin
no flags Details
Test file with english changed to English(USA) (10.27 KB, application/vnd.oasis.opendocument.text)
2012-10-01 06:09 UTC, jentzmin
no flags Details
Side by side comparison of Language Settings for "New" text document (right click vs. Start>Programs) (16.63 KB, image/png)
2013-02-11 03:40 UTC, Ozelle
no flags Details
Screen shots of bug replicated in OO Writer (798.84 KB, text/plain)
2013-09-24 14:40 UTC, ktruex2012
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Hankorama 2012-03-21 01:13:17 UTC
Created attachment 77348 [details]
Spelling and Grammar not working : sample

OpenOffice.org 3.3.0
OOO330m20 (Build: 9567)

Operating Systems Tested : Windows XP Professional; Windows 7
Hardware: Lenovo Desktop; Dell Inspiron Laptop

Program Language used: English
Default Language(Tools\Options\Language): English USA

The Spelling and Grammar checker fails to work dependant on how the document is is created.  

If the document is created by accessing OpenOffice Writer from the Start Menu it works fine.

If the document is created by right clicking in the destination folder the problem appears.  
To reproduce the problem: 
1.Right click within the destination folder.
2. When the list appears select "New"
3. Then select "Open Document Text"
4. After the document opens successfully you will see that the Spelling and Grammar Checker does not work. 

No miss-spelled words or grammer errors are underlined.  Also, if you manually run the Spelling and Grammar check from the tool bar button the dialogue appears.  However, it produces a message "The spell check is complete" without catching any of the spelling or grammar errors and without going through the document.

This problem seems to persist for the life of the document.  It remains if the document is reopened. Reinstalling the Open Office software does not resolve the issue.  

None of the existing bugs appear to address this issue. 

A defective document is attached.
Comment 1 Hankorama 2012-03-21 01:18:28 UTC
I am not sure what category this should be in.  It appears related to the API that creates the file but it effects the Spelling and Grammar checker. 

Thank you for looking at this. The work around is inconvenient.
Comment 2 jentzmin 2012-10-01 06:08:30 UTC
OpenOffice.org 3.4.1
AOO341m1(Build:9593) – Rev 1372282

Default Language for OpenOffice: English(USA)
Default Language for Microsoft Word 2010: English(U.S.)

I was able to replicate this bug following the steps provided. The test file I created would not underline any spelling or grammatical errors and spelling and grammar check yielded no results. 

I opened the test file in Microsoft Word 2010 and the grammar and spelling underlining was not working in that application either.  Running the spell check in Microsoft Word prompted a message box stating "Could not find proofing tools for German(Germany). Check your Office Language Preferences to see if the required proofing tools are installed."  Checking the language settings in Word revealed that the language was indeed set to German and changing the language to English caused the spell check function to work again.  

I opened the non-working file in OpenOffice again and changed the language for all text to English(USA).  This immediately caused underlining to appear and the spell check function was working again as well.  Saving the file after changing the language appears to permanently fix the issue. 

I was able to follow these steps and reproduce this same outcome using my desktop and a Gateway laptop, both running Windows 8 Consumer Preview 64 - bit.  Attached are my test file and the same file saved with the language manually changed to English (USA).
Comment 3 jentzmin 2012-10-01 06:09:00 UTC
Created attachment 79701 [details]
Non-working test file
Comment 4 jentzmin 2012-10-01 06:09:26 UTC
Created attachment 79702 [details]
Test file with english changed to English(USA)
Comment 5 yunfei duan 2012-10-03 02:03:12 UTC
Windows XP OOo 3.4.0 the same problem 
(1) right click the destination folder and click new, open a new OOo writer text and type some letters after type the word the grammar and spelling correct tool doesn’t’ t work
(2) from the start button open a new OOo writer it seems has the same situation and I found that if the word has four letters including four it works E.G love this word can correct in the OOo automatically but the grammar and spell tool can’t work either
(3) click the OOo icon on the desktop and create a new OOo writer the problem is similar to (2)
From the one comment that mention about set the language to EnglishI follow the steps but it doesn’t work. I try to set the language through the options, it cannot work too. In (1) if the letter is 4 (love like)it can correct the spelling automatically but not all the 4 letters word, the four letter can automatically correct because of the AutoCorrect options that has a form including some basic words can use to correct the word E.G if I type liek and it turns to like immediately 
Windows 7 OOo 3.4.1 
In win 7 I do the same step that in win XP 
(1) right click the destination folder and click new, open a new OOo writer text and type some letters after typing  the word the grammar and spelling correct tool doesn’t’ t work and also the automatically error correction  
(2) from the start button open a new OOo writer it can works well both the tool and automatically error correction  
(3) click the OOo icon on the desktop and create a new OOo writer can work in the same way as (2)
Then follow the steps that 
In the (1) we can change the language from the tool bar click tool => language => for all text => English(USA) and then the grammar and spelling can works well 
Windows 8 OOo 3.4.1 & Microsoft word 2012
do not have that problem in OOo 3.4.1 neither of Microsoft word 2012
Comment 6 Ozelle 2013-02-11 03:40:10 UTC
Created attachment 80256 [details]
Side by side comparison of Language Settings for "New" text document (right click vs. Start>Programs)

OS used to reproduce issue: Windows XP Professional
OpenOffice.org 3.3.0
OOO330m20 (Build: 9567)

Additional Information I thought may be helpful: 
-Default languages (Tools > Options > Language Settings > Languages) are different depending on how the document is created (Start Menu vs. right-clicking and creating a "New > OpenDocument Text") - screen shot attached.  

I noted how the default language for the new document created via right-click was not one that had an ABC check flag to the left of it while the new document created via Start > Programs did have a default language with an ABC check flag to the left of it.  

-Issue is not specific to Open Office Writer.  I was able to reproduce the exact same issues in OpenOffice.org Impress & Calc
     - Steps to reproduce in OpenOffice.org Impress
       1.  Right click on desktop or within a folder
       2.  Select "New" from menu options
       3.  Select "OpenDocument Text" from menu options
       4.  Select File > Add Slide
       5.  Enter misspelled text (either in the title or body of the slide)
As you noted, no misspelled words are underlined and manually running the ABC check ignores the spelling and grammar errors. 

It appears there are known issues with spell check in this version of OOo Writer, most suggesting to reset the user profiles.  I've done so but am still experiencing the bug.
Comment 7 Cem Kaner 2013-02-14 02:53:08 UTC
Same issue as 120610
Comment 8 ktruex2012 2013-09-24 14:40:01 UTC
Created attachment 81618 [details]
Screen shots of bug replicated in OO Writer
Comment 9 ktruex2012 2013-09-24 15:00:22 UTC
I was able to replicate this bug in Open Office Writer on my Windows 7 laptop with Open Office version 4.0.0 following the steps provided. If I create a new file using File->New->Text Document, any words misspelled are underlined red and when I run spell checker, it flags the words as being misspelled. When I create a new Text Document by navigating to my documents folder(destination folder), right clicking, selecting new text document, and then opening the document in OpenOffice Writer, any misspelled words that I type are not underlined red and when i run spell checker, it does not flag any words as being misspelled.
     I was also able to replicate this bug using the same machine with OpenOffice version 4.0.0 in Calc and Impress by following the steps provided. The only difference in steps is when you navigate to your documents folder(destination folder), right click, select new OpenDocument Presentation and Spreadsheet. When you open those documents in their respective applications, the bug is present as well. 
     I have also attached a document containing screen shots of the bug replicated in OpenOffice version 4.0.0 Writer.
Comment 10 Ariel Constenla-Haile 2013-09-24 15:07:10 UTC
(In reply to Cem Kaner from comment #7)
> Same issue as 120610

Yes.

*** This issue has been marked as a duplicate of issue 120610 ***
Comment 11 Ariel Constenla-Haile 2013-09-24 15:09:07 UTC
Closing duplicate.

This one is older, but the other one has more technical information and possible workarounds.