Issue 119134 - Arabic text are not using ligatures
Arabic text are not using ligatures
Status: UNCONFIRMED
Product: Writer
Classification: Application
Component: formatting
OOo 3.3
PC All
: P3 normal (vote)
: ---
Assigned To: AOO issues mailing list
: Arabic, needhelp
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 17:43 UTC by nicolas.brouard
Modified: 2014-04-14 19:10 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Arabic text excerpt without ligatures and wrong parentheses on OS/X. (12.11 KB, application/vnd.oasis.opendocument.text)
2012-03-26 17:43 UTC, nicolas.brouard
no flags Details
Arabic PDF excerpt with ligatures and correct parentheses on OS/X. (28.89 KB, application/pdf)
2012-03-26 17:45 UTC, nicolas.brouard
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description nicolas.brouard 2012-03-26 17:43:48 UTC
Created attachment 77376 [details]
Arabic text excerpt without ligatures and wrong parentheses on OS/X.

Arabic texts are using ligatures which are no more displayed in OpenOffice 3.3 (pick up whatever text in Google translate to Arabic, it will be well displayed, copy and paste into OpenOffice and you will understand how letters are single letters and not ligatures). 
 تقر
It was a main advantage over Microsoft Office to have it well displayed.

It is not related to the fonts.

On LibreOffice ligatures are OK but when mixing parentheses they are echoed )45( wrongly (numbers are left to right in Arabic even if the text is right to left).

Only neooffice seems to have something similar to previous Linux and Windows OpenOffice versions.
Comment 1 nicolas.brouard 2012-03-26 17:45:58 UTC
Created attachment 77377 [details]
Arabic PDF excerpt with ligatures and correct parentheses on OS/X.

The corresponding PDF file with Arabic text and correct ligatures and parentheses.
Comment 2 nicolas.brouard 2012-03-26 17:53:16 UTC
I haven't tested on Windows or Linux with latest OpenOffice. I came from a page related to OS/X bugs but I am discovering  that the bug is filed to 'PC'. Please test the Arabic odt file attached, see if it looks similar to the PDF (output from neoOffice) on Linux and Windows. If it is OK (as it was with former versions of OpenOffice), please file the bug to OS/X. 

Regards
Comment 3 nicolas.brouard 2012-06-05 09:54:07 UTC
See bug 119579 for wrong management of parentheses )8( instead of (8) for example. 

Still buggy in 3.4.0 on OS/X .
Comment 4 Ahmed 2013-11-15 04:51:58 UTC
Hello,

I'm using operating system: windows 7
oo version: AOO401m5(Build:9714)  -  Rev. 1524958


I couldn't replicate it, the first attachment works fine for me.