Issue 119195 - Shortcuts
Summary: Shortcuts
Status: CLOSED DUPLICATE of issue 4579
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 3.3
Hardware: PC All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-06 16:52 UTC by averyparris
Modified: 2012-04-08 09:50 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description averyparris 2012-04-06 16:52:49 UTC
Please make shortcuts for special characters.
In MS Word, to make shortcuts for special charcters, we go to the window of that special character and they have a box where we can enter a shortcut for that special symbol: Examples, we might choose ctrl o for the omega symbol.
Comment 1 hanya 2012-04-06 17:23:39 UTC
It seems this issue is duplicate of very old issue 4579.
Comment 2 Marcus 2012-04-06 17:33:35 UTC
yes, duplicate

*** This issue has been marked as a duplicate of issue 4579 ***
Comment 3 averyparris 2012-04-06 18:30:09 UTC
I am not sure, I think we are suppose to copy the macro from issue 4579. If so then it does not solve my problem. The macro doesn't show any Greek letters that scientists often use. It also doesn't show other characters that I want to use. 

And if I do want to use those that are available, how do we do it, as in what combination keys do we press?
Comment 4 Marcus 2012-04-08 09:35:09 UTC
My intention was to show that there is another issue that is dealing in general with this feature wish. That is why this issue is a duplicate to the other one.

Currently it's not possible to assign certain keys to specific chars from the Special Character dialog.

However, maybe someone has already a differnet solution in our User Forums:
http://user.services.openoffice.org

*** This issue has been marked as a duplicate of issue 4579 ***
Comment 5 hanya 2012-04-08 09:50:54 UTC
There are several workaround. We require GUI to assign but there is not yet provided.

- Assign recorded macro to a shortcut key
- Assign the command which to insert specific character using macro
- If you have the knowledge of extension, prepare the configuration as follows, and pack it into a package.
<?xml version="1.0" encoding="UTF-8"?>
<oor:component-data xmlns:oor="http://openoffice.org/2001/registry" 
    xmlns:xs="http://www.w3.org/2001/XMLSchema" 
    xmlns:install="http://openoffice.org/2004/installation" 
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
    oor:name="Accelerators" 
    oor:package="org.openoffice.Office">
    <node oor:name="PrimaryKeys">
        <node oor:name="Modules">
            <node oor:name="com.sun.star.text.TextDocument" oor:op="fuse">
                <node oor:name="O_MOD2" oor:op="replace">
                    <!-- Omega -->
                    <prop oor:name="Command">
                        <value xml:lang="en-US">.uno:InsertSymbol?Symbols:string=&#x3A9;</value>
                    </prop>
                </node>
            </node>
        </node>
    </node>
</oor:component-data>

So, if you require more help, please go to the user's forum.