Issue 119208 - Cannot select a different icon set
Summary: Cannot select a different icon set
Status: RESOLVED FIXED
Alias: None
Product: ui
Classification: Code
Component: icon (show other issues)
Version: AOO340-dev
Hardware: PC All
: P2 Major (vote)
Target Milestone: 4.1.4
Assignee: Ariel Constenla-Haile
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-09 23:13 UTC by Andrea Pescetti
Modified: 2017-10-12 21:29 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.3
Developer Difficulty: ---
jsc: 3.4_release_blocker-
arielch: 4.1.4_release_blocker+


Attachments
Current status in branches/AOO414/extras/l10n/source (23.15 KB, text/plain)
2017-02-02 15:53 UTC, Ariel Constenla-Haile
no flags Details
Strings in different status (4.07 KB, text/plain)
2017-02-03 02:16 UTC, Ariel Constenla-Haile
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Andrea Pescetti 2012-04-09 23:13:31 UTC
On the latest dev build (Ariel's r1310206, 64-bit RPM, Italian) I cannot
change the icon set used. Whatever I choose in Tools - Options - View, the
default icon style is set to "Automatico ()" and while 4 options to change
it are listed (Galaxy, Contrasto Elevato - High Contrast, Industrial, Tango)
neither of them produces any visible effect.

Setting P2 because of accessibility concerns (High Contrast set).
Comment 1 Armin Le Grand 2012-04-10 13:07:04 UTC
ALG: Checked on windows, indeed the theme cannot be changed, but small/large works well. Also checked that AOO changes to high contrast icons when the system is on high contrast, this works flawlessly.
Comment 2 Rob Weir 2012-04-10 13:35:38 UTC
Checked on clean XP SP3 install.  I cannot change the icon set via the dialog.  No error messages.  But the icon set does not change.

But if I use the Windows XP Accessibility Options dialog (through the XP Control Panel)I can turn on high-contrast and the icons change then.

So it looks like an issue with our dialog.
Comment 3 sorath 2012-04-10 19:18:20 UTC
I confirm both for Linux 64bit and for Windows - I cannot change icon set. 

I can change icon size (small or big) but this changes applied only after restart of AOO 3.4.0 while in OOo-3.3.0 no need to restart after change of icon set or icon size.
Comment 4 Andrea Pescetti 2012-04-15 12:32:28 UTC
Updating platform to ALL. If this can help, Pedro sent a link to
http://svn.apache.org/viewvc/incubator/ooo/trunk/main/vcl/inc/vcl/settings.hxx?r1=1206244&r2=1206243&pathrev=1206244
that shows how the Crystal icons were removed and also shows that we rely on fixed numerical IDs, that could make updates problematic.

However, in builds made after that update it was still possible to change icon set (but wrong names for the icon sets were displayed, at least in the Italian and Spanish versions); now the names seem correct, but the icon set does not change.
Comment 5 Andrea Pescetti 2012-04-15 15:49:01 UTC
Be sure we evaluate whether this is a Release Blocker or not and, if not, if we should refer to this known problem in the Release Notes or not.
Comment 6 Ariel Constenla-Haile 2012-04-15 17:42:57 UTC
The issue is caused because "Tango" has been remove from the listbox string item list: main/cui/source/options/optgdlg.src#252

    242     ListBox LB_ICONSTYLE
    243     {
    244         HelpID = "cui:ListBox:OFA_TP_VIEW:LB_ICONSTYLE";
    245         Pos = MAP_APPFONT ( 61 , ROW_LB_ICONSIZESTYLE ) ;
    246         Size = MAP_APPFONT ( 65 , 70 ) ;
    247         DropDown = TRUE ;
    248         Border = TRUE ;
    249         TabStop = TRUE ;
    250         StringList [ en-US ] =
    251         {
    252             < "Automatic" ; > ;
    253             < "Galaxy (default)" ; > ;
    254             < "High Contrast" ; > ;
    255             < "Industrial" ; > ;
    256             < "Classic" ; > ;
    257         };
    258     };

but not from the constants in main/vcl/inc/vcl/settings.hxx#485

    485 #define STYLE_SYMBOLS_AUTO		((sal_uLong)0)
    486 #define STYLE_SYMBOLS_DEFAULT		((sal_uLong)1)
    487 #define STYLE_SYMBOLS_HICONTRAST	((sal_uLong)2)
    488 #define STYLE_SYMBOLS_INDUSTRIAL	((sal_uLong)3)
    489 #define STYLE_SYMBOLS_TANGO		((sal_uLong)4)
    490 #define STYLE_SYMBOLS_CLASSIC		((sal_uLong)5)
    491 #define STYLE_SYMBOLS_THEMES_MAX	((sal_uLong)6)

This way, the listbox has by default 5 items, but STYLE_SYMBOLS_THEMES_MAX is 6; then, in OfaViewTabPage's constructor the array aIconStyleItemId has trash because it is never initialized, as the condition is false:
main/cui/source/options/optgdlg.cxx#769

    769     if( aIconStyleLB.GetEntryCount() == STYLE_SYMBOLS_THEMES_MAX )
    770     {
    771         // do not check 0th item == auto; it is not a real theme
    772         aIconStyleItemId[0] = 0;
    773         sal_uLong nItem = 1;
    774         for ( sal_uLong n=0; ++n < STYLE_SYMBOLS_THEMES_MAX; )
    775         {
    776             if ( aStyleSettings.CheckSymbolStyle( n ) )
    777             {
    778                 // existing style => save the item id
    779                 aIconStyleItemId[n] = nItem++;
    780             }
    781             else
    782             {
    783                 // non-existing style => remove item;
    784                 aIconStyleLB.RemoveEntry( nItem );
    785                 aIconStyleItemId[n] = 0;
    786             }
    787         }
    788     }

aIconStyleLB.GetEntryCount() == STYLE_SYMBOLS_THEMES_MAX
5 != 6

And then everything else will fail.
Comment 7 Pedro Giffuni 2012-04-15 21:47:21 UTC
Ugh.. the issue is clearly a regression so it classifies as
a release blocker. 

Instead of discussing if it is a serious issue or not, I just
went ahead and committed the fix:

Sending        vcl/inc/vcl/settings.hxx
Transmitting file data .
Committed revision 1326423.
Comment 8 Pedro Giffuni 2012-04-16 02:53:44 UTC
Revision 1326423 removed STYLE_SYMBOLS_TANGO since it doesn't exist
anymore, however the .sdf files still need to be updated as the
Tango icon set is not valid anymore.

Ideally they should be updated from Pootle (?).
Comment 9 Pedro Giffuni 2012-04-16 02:53:44 UTC
Revision 1326423 removed STYLE_SYMBOLS_TANGO since it doesn't exist
anymore, however the .sdf files still need to be updated as the
Tango icon set is not valid anymore.

Ideally they should be updated from Pootle (?).
Comment 10 jsc 2012-04-16 15:32:26 UTC
as discussed on the mailing list, it is no show stopper and we will fix it asap for the next release
Comment 11 Pedro 2014-08-23 11:40:49 UTC
This bug seems to be fixed (at least under Windows OS using version 4.1.1). However the Tango icon set is still missing. Was it deliberately removed? Or is there a separate bug report?
Comment 12 Andrea Pescetti 2014-08-23 19:13:02 UTC
The bug is fixed, see http://svn.apache.org/r1326423 and the other comments.

And yes, Tango has been intentionally removed (license conflict) and won't be back.

Only the minor issue of updating SDF files remains open, but this should be minor for only one string.
Comment 13 Matthias Seidel 2017-01-10 18:01:44 UTC
Fixed in Pootle for the German version.
After so many years, maybe this could be integrated in 4.1.4?
Comment 14 Ariel Constenla-Haile 2017-01-23 15:32:28 UTC
(In reply to Matthias Seidel from comment #13)
> Fixed in Pootle for the German version.
> After so many years, maybe this could be integrated in 4.1.4?

Please request release blocker.
Comment 15 Matthias Seidel 2017-01-23 15:51:52 UTC
(In reply to Ariel Constenla-Haile from comment #14)
> (In reply to Matthias Seidel from comment #13)
> > Fixed in Pootle for the German version.
> > After so many years, maybe this could be integrated in 4.1.4?
> 
> Please request release blocker.

Release-Blocker for this issue?

The issue itself is fixed only Pootle integration is missing...
But if it is OK I will request.
Comment 16 Ariel Constenla-Haile 2017-01-23 18:17:44 UTC
(In reply to Matthias Seidel from comment #15)
> > > Fixed in Pootle for the German version.
> > > After so many years, maybe this could be integrated in 4.1.4?
> > 
> > Please request release blocker.
> 
> Release-Blocker for this issue?
> 
> The issue itself is fixed only Pootle integration is missing...

Yes, but for which languages is the fix needed? You seem to confirm German, but this bug doesn't tell anything about the languages that are affected. IMO we should investigate every language that will be released, and if the fix is in pootle, merge at least this resource string.

The locations in pootle are:

optgdlg.src#OFA_TP_VIEW.LB_ICONSTYLE.1.stringlist.text
optgdlg.src#OFA_TP_VIEW.LB_ICONSTYLE.2.stringlist.text
optgdlg.src#OFA_TP_VIEW.LB_ICONSTYLE.3.stringlist.text
optgdlg.src#OFA_TP_VIEW.LB_ICONSTYLE.4.stringlist.text
optgdlg.src#OFA_TP_VIEW.LB_ICONSTYLE.5.stringlist.text
Comment 17 Matthias Seidel 2017-01-23 19:02:49 UTC
Yes, I fixed the (only) affected

optgdlg.src#OFA_TP_VIEW.LB_ICONSTYLE.5.stringlist.text

for german. (Tango -> Klassisch)

Maybe a mail to l10n@ with a request to native speaking translators could help?
Comment 18 Matthias Seidel 2017-02-01 22:02:14 UTC
I looked up

optgdlg.src#OFA_TP_VIEW.LB_ICONSTYLE.5.stringlist.text

in every language that we release builds for. Most were translated for "Classic", the remaining translations for "Tango" are corrected now.

So at least this resource string should be merged.

I will ask for release blocker for 4.1.4.
Comment 19 Ariel Constenla-Haile 2017-02-02 15:53:19 UTC
Created attachment 85948 [details]
Current status in branches/AOO414/extras/l10n/source

The file contains the current strings in the SDF files of all the languages we release.

It seems that at least five languages contain "Tango".
Comment 21 Matthias Seidel 2017-02-02 22:06:28 UTC
In this case (greek) I took it from:

sdstring.src#RID_SVXSTR_COLOR_BLUE_CLASSIC.string.text (Blue classic)

But there is a difference between "κλασικός" (Classic) and "κλασσικός" (Classical). (Says Google Translate).

In German "Klassisch" (Classical) was used before...

For Korean I have asked a native speaker (we translate the homepage together), the translation means sort of "old version".


But isn't there a way to restore the old strings for Classic?
They did exist in older releases and got lost at one point when Tango was deleted.
Comment 22 Ariel Constenla-Haile 2017-02-03 00:13:50 UTC
(In reply to Matthias Seidel from comment #21)
> But isn't there a way to restore the old strings for Classic?
> They did exist in older releases and got lost at one point when Tango was
> deleted.

In theory (and ideally) Pootle should keep a translation history, but if they created a new Pootle project instead of updating an existing one, the history might not be kept.

We can use subversion history, for example:
https://svn.apache.org/viewvc/openoffice/branches/AOO414/extras/l10n/source/el/localize.sdf?view=log

Revision 1499324 removed the strings, Revision 1413471 has

cui	source\options\optgdlg.src	0	stringlist	OFA_TP_VIEW.LB_ICONSTYLE	8			0	el	Κλασσικό				2002-02-02 02:02:02
Comment 24 Ariel Constenla-Haile 2017-02-03 01:52:47 UTC
(In reply to Ariel Constenla-Haile from comment #23)
> The old SDFs can be retrieved with the following commands:

For some languages we need an older revision, as translations where integrated earlier:

de, fi, km, ko, pt-BR: revision 1229431
el, eu, hi: revision 1413471
Comment 25 Ariel Constenla-Haile 2017-02-03 02:16:28 UTC
Created attachment 85950 [details]
Strings in different status

For each language, there are three lines:

- the current status of the SDF file in branch AOO414
- the string as translated in Pootle right now
- the string before merging the string list with fewer items, in this case Classic corresponds to OFA_TP_VIEW.LB_ICONSTYLE.8 instead of OFA_TP_VIEW.LB_ICONSTYLE.5
Comment 26 Ariel Constenla-Haile 2017-02-03 03:05:55 UTC
Comparing the string, I came to this conclusion:

- de: keep the pootle translation, Klassisch
- el: keep the old string, Κλασσικό, same as in pootle now
- eu: keep the old string, Klasikoa (in pootle it was Klasiko)
- fi: keep the old string, Perinteinen (in pootle it was Klassinen)
- hi: keep the old string, क्लासिक, same as in pootle now (the current sdf has उत्कृष्ट)
- km: keep the pootle translation, សាមញ្ញ; the old one is ក្លាស់ស៊ិក, in the std it is តាំងហ្គោ
- pt-BR: keep the old string, same as in pootle now (the current sdf has Tango)
Comment 27 SVN Robot 2017-02-04 20:54:09 UTC
"arielch" committed SVN revision 1781705 into branches/AOO414:
i119208 - Update Classic icon set name translation
Comment 28 SVN Robot 2017-02-04 20:56:18 UTC
"arielch" committed SVN revision 1781706 into trunk:
i119208 - Update Classic icon set name translation
Comment 29 Ariel Constenla-Haile 2017-02-04 20:57:34 UTC
Fixed on trunk and branch AOO414
Comment 30 Kay 2017-10-12 21:29:54 UTC
Fixed for Linux-32, 4.1.4RC5, Rev. 1811857