Issue 119302 - spellcheck doesn't work
Summary: spellcheck doesn't work
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.3
Hardware: PC Windows 7
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-01 11:19 UTC by vtrust
Modified: 2017-05-20 10:15 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
writing aids module (215.60 KB, image/jpeg)
2012-05-01 11:19 UTC, vtrust
no flags Details
Spell check does NOT work at all (8.46 KB, application/vnd.oasis.opendocument.text)
2012-06-24 17:50 UTC, Larry
no flags Details
Extension Manager with only dict-en.oxt enabled (62.76 KB, image/png)
2012-06-25 17:37 UTC, Ariel Constenla-Haile
no flags Details
Spell check working on the attached bug document (61.78 KB, image/png)
2012-06-25 17:38 UTC, Ariel Constenla-Haile
no flags Details
Options->Languages and Extension Manager (69.40 KB, image/jpeg)
2012-06-25 21:27 UTC, Frann Leach
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description vtrust 2012-05-01 11:19:07 UTC
Created attachment 77506 [details]
writing aids module

Can't load spellcheck properly. The spellcheck button is on but doesn't load the program. No corrective red line. Spelling [F7] doesn't have any language in. Have English US, UK, German, Spanish. US English appears dimmed.
Comment 1 Frann Leach 2012-05-07 19:28:11 UTC
Hasn't worked for a long time. I thought it was something I'd done, but as I had to do a clean install of Ubuntu and all my software recently and it still isn't working, it's obviously a bug.
Comment 2 Frann Leach 2012-05-07 19:31:05 UTC
Hasn't worked for a long time. I thought it was something I'd done, but as I had to do a clean install of Ubuntu and all my software recently and it still isn't working, it's obviously a bug.
Comment 3 Du Jing 2012-05-28 02:47:43 UTC
can'r reproduce in AOO3.4.
Comment 4 Terry Yang 2012-06-12 02:06:25 UTC
Can you please check is the Spell check extension is installed and enable in your AOO?
If not please install the extentions and try it again.

It is work fine at my side.
Comment 5 Larry 2012-06-24 17:50:13 UTC
Created attachment 78449 [details]
Spell check does NOT work at all

From truly misspelled words to a string of random characters Open Office Writer 3.4 will not flag any words as being incorrect. I have my version set for English(USA), standard and soffice dictionaries. The attachment is a set of four random strings of characters, not recognizable as being words in the English language and yet OpenOffice 3.4 spell check deems these 4 strings as being spelled correctly.
Comment 6 Ariel Constenla-Haile 2012-06-24 19:26:29 UTC
(In reply to comment #5)
> Created attachment 78449 [details]
> Spell check does NOT work at all
> 
> From truly misspelled words to a string of random characters Open Office
> Writer 3.4 will not flag any words as being incorrect. I have my version set
> for English(USA), standard and soffice dictionaries. The attachment is a set
> of four random strings of characters, not recognizable as being words in the
> English language and yet OpenOffice 3.4 spell check deems these 4 strings as
> being spelled correctly.

How many dictionary extensions have you installed and for which languages?

There are issues with the dictionary extensions that affect the Thesaurus, and likely also spell checking.

It is recommended to have only one extension per language. For English, you can install http://numbertext.org/tmp/dict-en.oxt
It supports the following locales: en-GB en-US en-ZA en-AU en-CA
Comment 7 Frann Leach 2012-06-25 17:22:55 UTC
(In reply to comment #6)
> It is recommended to have only one extension per language. For English, you
> can install http://numbertext.org/tmp/dict-en.oxt
> It supports the following locales: en-GB en-US en-ZA en-AU en-CA

I have several dictionaries installed for English. I can't find out how to uninstall them so that I can install the one you recommend (though the list seems to match the supported locales you mention, so perhaps I already have it).

There are threads that say to change dictionary.lst, but after a search for this file all I found were 2 README.dictionary.lst files, which state that in version >3 there is no such file.
Comment 8 Ariel Constenla-Haile 2012-06-25 17:32:05 UTC
(In reply to comment #7)
> > It is recommended to have only one extension per language. For English, you
> > can install http://numbertext.org/tmp/dict-en.oxt
> > It supports the following locales: en-GB en-US en-ZA en-AU en-CA
> 
> I have several dictionaries installed for English. I can't find out how to
> uninstall them so that I can install the one you recommend (though the list
> seems to match the supported locales you mention, so perhaps I already have
> it).

Dictionaries are installed with extensions.
Go to the menu "Tools" - "Extension Manager..."
This will open a new window with the "Extension Manager". Select an extension from the list, and you'll see a button "Disable" and another one "Remove". Removing some extensions may require you have administrative privileges in your computer, so better try to disable the extensions by pressing the "Disable" button.

Once disabled all dictionary extensions, download http://numbertext.org/tmp/dict-en.oxt (though I guess you already have this extension installed, I'll attach a screenshot to show how to recognize this extension in the "Extension Manager"

> There are threads that say to change dictionary.lst, but after a search for
> this file all I found were 2 README.dictionary.lst files, which state that
> in version >3 there is no such file.

This is all old stuff. Now dictionaries are installed as extensions.
Comment 9 Ariel Constenla-Haile 2012-06-25 17:37:33 UTC
Created attachment 78468 [details]
Extension Manager with only dict-en.oxt enabled

Disable all English dictionary extensions, leaving only the one you can see in the screen shot: it says "English spelling and hyphenation dictionaries and thesaurus 2010.03.16"

You must restart Apache OpenOffice (close also the Quickstarter icon on the system tray), and spelling should work.
Comment 10 Ariel Constenla-Haile 2012-06-25 17:38:24 UTC
Created attachment 78469 [details]
Spell check working on the attached bug document
Comment 11 Frann Leach 2012-06-25 21:27:20 UTC
Created attachment 78470 [details]
Options->Languages and Extension Manager
Comment 12 Frann Leach 2012-06-25 21:28:47 UTC
Attached above is a screenshot mashup showing Options->Languages and Extension Manager. Though no dictionaries are shown in the latter, I have a choice of several different English dictionaries in the former...
Comment 13 Ariel Constenla-Haile 2012-06-25 21:49:45 UTC
(In reply to comment #12)
> Attached above is a screenshot mashup showing Options->Languages and
> Extension Manager. Though no dictionaries are shown in the latter, I have a
> choice of several different English dictionaries in the former...

These are different things:

- "Tools" - "Options" - "Language Settings" - "Languages" - "Language of" - "User interface": in this list box, you will see all "language(s) used for the user interface, for example menus, dialogs, help files. You must have installed at least one additional language pack or a multi-language version of OpenOffice.org.
The "Default" entry selects the language of the user interface for the operating system. If this language is not available in the OpenOffice.org installation, the language of the OpenOffice.org installation is the default language." [For the Help - press F1]
This means you have installed additional language packs at least for two of the three locales in this listbox.
This list box has nothing to do with the Spell checker, it sets only the user interface (menus, dialogs, help files).

You can check if the Spell checker is working in the same Options dialogs, but under "Language Settings" - "Writing Aids". On "Available language modules" you should see "Hunspell SpellChecker" *only* if you have at least one dictionary installed.

You don't have any dictionary extension listed on the extension Manager, so you don't have SpellChecker.


This is rather strange, because the default install set downloaded from the OpenOffice.org web site only comes with a language for the user interface (you have three in the listbox), and a respective dictionary (you have none).

What version of OOo are you using? Did you download it from the OOo web site?
Comment 14 Larry 2012-06-27 01:54:01 UTC
I downloaded the program as an "update" from my old version of OO. Within minutes I had gone from a perfectly working copy of software with full dictionary and thesaurus support to this new, improved version with zero spell check capability and no thesaurus. 

What I would really like is to have my 'old' version back and trash the new and improved Apache version. As for not having any dictionaries selected? Three of the four are selected at Options > Languages > Writing Aids > User-Defined Dictionaries.
Comment 15 Ariel Constenla-Haile 2012-06-27 02:30:55 UTC
(In reply to comment #14)
> I downloaded the program as an "update" from my old version of OO. Within
> minutes I had gone from a perfectly working copy of software with full
> dictionary and thesaurus support to this new, improved version with zero
> spell check capability and no thesaurus. 

I understand this is rather frustrating, but the spell check capability is present, it happens that you don't have any dictionary extension installed.

> What I would really like is to have my 'old' version back and trash the new
> and improved Apache version. 

You will have to remove this version, and install the older back. I'd suggest you also remove your user profile.

> As for not having any dictionaries selected?
> Three of the four are selected at Options > Languages > Writing Aids >
> User-Defined Dictionaries.

The User-Defined Dictionaries will not work for Thesaurus/Spell checking, you need to install dictionary extensions.

The fact that you don't have any dictionary extension at all shows something went wrong during the installation, because AOO 3.4.0 installs 4 English dictionary extensions.

If your installation isn't completely broken, the solution may be as simple as installing any extension:

- download the English dictionary extension: http://numbertext.org/tmp/dict-en.oxt
- Go to the menu "Tools" - "Extension Manager..."
- In the Extension Manager press the button "Add...", a file dialog will show up
- in the file dialog, browse to the folder where you stored the extension, and select the dictionary extension
- the installation of the extension will start
- close OpenOffice (including the Quickstarter icon on the system tray)
- Start OpenOffice again, spell checking and thesaurus should work
Comment 16 Rob Weir 2013-03-21 19:23:55 UTC
Unfortunately we were not able to reproduce this.