Issue 119392 - Make GTK Quickstarter buildable with gtk 2.10.x
Summary: Make GTK Quickstarter buildable with gtk 2.10.x
Status: RESOLVED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 3.4.0
Hardware: PC Unix, all
: P3 Normal (vote)
Target Milestone: 4.0.0
Assignee: Ariel Constenla-Haile
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 119385
  Show dependency treegraph
 
Reported: 2012-05-21 03:10 UTC by Ariel Constenla-Haile
Modified: 2012-11-27 13:59 UTC (History)
0 users

See Also:
Issue Type: TASK
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Ariel Constenla-Haile 2012-05-21 03:10:12 UTC
Currently, the GTK Quickstarter uses some GTK API that requires GTK >= 2.16
http://developer.gnome.org/gtk/2.24/GtkStatusIcon.html#gtk-status-icon-get-tooltip-text

or GTK >= 2.14
http://developer.gnome.org/gtk/2.24/GtkStatusIcon.html#GtkStatusIcon-button-press-event

It would be desirable to use only GTK 2.10 API.
Comment 1 Ariel Constenla-Haile 2012-05-21 03:10:55 UTC
Started
Comment 2 Ariel Constenla-Haile 2012-05-21 09:30:14 UTC
For updating the System requirements in the documentation (README and website) there is a separated Bug 119393
Comment 3 Ariel Constenla-Haile 2012-06-21 23:15:58 UTC
Fixed in revision 1352725

The GTK Quickstarter can be build in CentOS 5 with gtk 2.10

Tested that it works fine in CentOS 5 and Fedora 17 with gtk2 (2.24.10) and gtk3 (3.4.3).