Issue 119537 - [From Symphony]<Shape><Extrusion>The Extrusion direction of shape can't be saved correctly
[From Symphony]<Shape><Extrusion>The Extrusion direction of shape can't be sa...
Status: CLOSED FIXED
Product: Calc
Classification: Application
Component: formatting
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 02:43 UTC by Terry Yang
Modified: 2012-12-26 08:37 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Sample file (14.00 KB, application/vnd.ms-excel)
2012-05-30 02:43 UTC, Terry Yang
no flags Details
Patch for 3D Extrusion direction (889 bytes, patch)
2012-06-19 11:32 UTC, Jianyuan Li
awf.aoo: review+
Details | Diff
UT file for this issue (15.00 KB, application/octet-stream)
2012-06-19 11:33 UTC, Jianyuan Li
no flags Details
Root cause for this defect (11.77 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-06-20 13:32 UTC, Jianyuan Li
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Terry Yang 2012-05-30 02:43:51 UTC
Created attachment 77745 [details]
Sample file

1. Launch AOO3.4 and open the sample file;
2. Save it to a new .xls file.
2. Open the new file and Compare the Extrusion direction of custom shape with the oringnal  in MS Office Word 2003

               		 		  		 		   
Defect:
 The Extrusion direction of custom shape was saved incorrectly
Comment 1 Jianyuan Li 2012-06-18 09:59:26 UTC
I am investigating this issue.
Comment 2 Jianyuan Li 2012-06-19 07:03:45 UTC
I have tried the 9 kinds of extrusions direction in Excel 2003. Only for the 1,4,8 and 9 extrusion direction, AOO cannot export them successfully. There is no a individual property to express the 9 directions. A direction is described by two property "view point(X,Y,Z)" and "origin(X,Y)".

Root cause: when import, AOO does not set a correct view point x/y and origin x/y into to core function. So when export, an incorrect x/y is exported. Excel 2003 cannot recognize them.

Solution: When import, set a correct view point x/y and origin x/y into core function for the four(1,4,8 and 9) extrusion directions. For 1 and 4, view point x and origin x is not set(default). For 8 and 9, view point y and origin y is not set(default). When we set those values to core function, need set a correct value for them to prepare a correct value for export. Please check the attachment "root cause.ods". It is a result when import. To compare with the one which can be imported correctly. We can know the default value should be:
view point X:  1250000
view point Y: -1250000
origin X: 32768
origin Y:-32768
Comment 3 Jianyuan Li 2012-06-19 07:14:58 UTC
1250000=3472.2222222222222*360
32768=0.5*65536
"3472.2222222222222" and "0.5" is the result in attachment for root cause. Above the transformation in code for them. From those relations, default value can be obtained.
Comment 4 Terry Yang 2012-06-19 09:19:39 UTC
Update with detail steps
1. Launch AOO3.4 and open the sample file, check the Extrusion direction, the setting and the Shape display both south east which is same as open in MS office.

2. Save it to a new .xls file.

2. Open the new saved file in MS office, check the shape direction setting, The setting lost,  There is  no value in the setting.  Also the shape display is not same as the original file display in MS office, after we select the direction to south east, it display correct.
               		 		  		 		   
Defect:
The Extrusion direction setting of custom shape Lost after saved the file in AOO and open in MS office.
Comment 5 Jianyuan Li 2012-06-19 11:16:04 UTC
The default value change for "1250000" has been updated by the fix of issue 119554. Here my fix is only for the default value "32768".
Comment 6 Jianyuan Li 2012-06-19 11:32:43 UTC
Created attachment 78391 [details]
Patch for 3D Extrusion direction
Comment 7 Jianyuan Li 2012-06-19 11:33:22 UTC
Created attachment 78392 [details]
UT file for this issue
Comment 8 Jianyuan Li 2012-06-20 13:32:07 UTC
Created attachment 78406 [details]
Root cause for this defect
Comment 9 Andre 2012-06-21 11:30:26 UTC
Comment on attachment 78391 [details]
Patch for 3D Extrusion direction

Reviewed and commited in SVN revision 1352497.
Comment 10 Andre 2012-06-21 11:30:45 UTC
Setting status to fixed.
Comment 11 Andre 2012-06-21 12:41:22 UTC
I mixed up two patches (there way to many at the moment).
SVN revision 1352497 mentioned above belongs to bug 119903.

I have checked in the patch for this issue in SVN revision 1352519.
Comment 12 Terry Yang 2012-08-20 02:52:49 UTC
Verify fixed on revision 1374181.
Comment 13 Terry Yang 2012-08-20 02:53:35 UTC
Close this bug