Issue 119579 - [From Symphony]][BIDI]The position and direction of Right bracket is incorrect in Arabic locale
[From Symphony]][BIDI]The position and direction of Right bracket is incorrec...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: WangZhe
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 07:28 UTC by Li Feng Wang
Modified: 2012-10-18 06:59 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (55.24 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2012-05-30 07:28 UTC, Li Feng Wang
no flags Details
screenshot of open result (41.40 KB, image/png)
2012-05-30 07:29 UTC, Li Feng Wang
no flags Details
Fix patch for this issue (901 bytes, patch)
2012-08-23 06:44 UTC, Ma Bingbing
jiazema: review?
Details | Diff
sample file 2 (35.84 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2012-08-23 06:54 UTC, Ma Bingbing
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-05-30 07:28:45 UTC
Created attachment 77795 [details]
sample file

build:
AOO3.4 r1327774

steps:
0.Change the OS local to Arabic then install AOO3.4 Arabic.
1.Launch AOO3.4,open the attached sample files.

defect:
The position and direction of Right bracket is incorrect.
screenshot is in attachment
Comment 1 Li Feng Wang 2012-05-30 07:29:41 UTC
Created attachment 77797 [details]
screenshot of open result
Comment 2 Ma Bingbing 2012-08-23 05:30:25 UTC
I will take care this defect:
Root cause:
  Property name and value for bidi writing mode were incorrect.
Comment 3 Ma Bingbing 2012-08-23 06:40:03 UTC
Resolution:
    Set the property WritingMode instead of TextWritingMode. Also set its value to WritingMode2 instead of WritingMode. 
    And WritingMode2 is used to numerous explicit writing directions, it allows allows to specify to take the writing direction from the object's context.
Comment 4 Ma Bingbing 2012-08-23 06:44:48 UTC
Created attachment 79082 [details]
Fix patch for this issue
Comment 5 Ma Bingbing 2012-08-23 06:54:29 UTC
Created attachment 79083 [details]
sample file 2

Test case1:
  1.Change the OS local to Arabic then install AOO3.4 Arabic.
  2.Launch AOO and open the attached sample files.  

Test case2:
  Launch AOO and,open the attached sample files  

Test result:
  pass
Comment 6 Li Feng Wang 2012-08-24 07:32:08 UTC
Verify pass with attachment patch on Windows XP
Comment 7 WangZhe 2012-09-07 03:25:23 UTC
I'll take this one
Comment 8 WangZhe 2012-09-07 04:46:36 UTC
Delivered At revision: 1381862
Comment 9 Li Feng Wang 2012-09-18 08:31:41 UTC
can't reproduce on trunk r1384699
Comment 10 Shenfeng Liu 2012-10-18 06:59:42 UTC
Update Target Milestone to AOO 3.5.0.