Issue 119637 - [From Symphony] Function "Case sensitive" in "Special Filter" dialog can not work.
[From Symphony] Function "Case sensitive" in "Special Filter" dialog can not ...
Status: CLOSED FIXED
Product: Calc
Classification: Application
Component: code
OOo 3.4 Beta
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 09:23 UTC by binguo
Modified: 2012-11-07 08:55 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Sample file can repro this bug. (9.12 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-05-31 09:23 UTC, binguo
no flags Details
patch (1.21 KB, patch)
2012-07-26 07:59 UTC, Clarence GUO
orw: review+
Details | Diff
patch (1.21 KB, patch)
2012-07-26 08:08 UTC, Clarence GUO
orw: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description binguo 2012-05-31 09:23:00 UTC
Created attachment 77863 [details]
Sample file can repro this bug.

Steps:
1. Open the sample file.
2. Special filter Month="February" and check "Case sensitive" in the group "Options"
3. Check the result of Specical Filter in SC editor

Defect : 
No Correct result of Specical Filter show.
Comment 1 Clarence GUO 2012-07-02 05:11:40 UTC
The special filter means "advanced filter" I think. I'm working on this issue
Comment 2 Clarence GUO 2012-07-26 07:59:42 UTC
Created attachment 78735 [details]
patch

Root Cause:
In method ScTable::CreateExcelQuery, the filter string was converted to capital, no matter case sensitive or case insensitive. But after that, it will use case sensitive to compare the string according to the bCaseSensi flag of rQueryParam(already set to true)

Solution:
Don't convert string. It's redundant because later all comparisons will be performed according to bCaseSensi flag of rQueryParam
Comment 3 Clarence GUO 2012-07-26 08:08:36 UTC
Created attachment 78737 [details]
patch

Root Cause:
In method ScTable::CreateExcelQuery, the filter string was converted to capital, no matter case sensitive or case insensitive. But after that, it uses case sensitive to compare the strings according to the bCaseSensi flag of rQueryParam( was set to true )

Solution:
Don't convert string. It's redundant because later it will use bCaseSensi flag of rQueryParam for string comparison.
Comment 4 SVN Robot 2012-07-27 08:00:28 UTC
"leiw" committed SVN revision 1366302 into trunk:
#i119637 Function "Case sensitive" in "Special Filter" dialog can not work.
Comment 5 Wang Lei 2012-07-28 05:01:33 UTC
The patch looks good. Submitted in SVN revision 1366302
Comment 6 Oliver-Rainer Wittmann 2012-08-01 11:23:03 UTC
Comment on attachment 78735 [details]
patch

patch reviewed by Wang Lei
Comment 7 Oliver-Rainer Wittmann 2012-08-01 11:23:14 UTC
Comment on attachment 78737 [details]
patch

patch reviewed by Wang Lei
Comment 8 Terry Yang 2012-08-20 02:20:06 UTC
Verify not fixed on revision 1372282 with attached sample file.
If we uncheck "Case sensitive" in the group "Options", it will fiter 2 result, but if we check "Case sensitive", no result get, we should get 1 result as expect.
Comment 9 Terry Yang 2012-08-20 02:46:39 UTC
Sorry please ignore my last comments, this bug fixed on build revision 1374181.
Comment 10 Terry Yang 2012-08-20 02:47:03 UTC
Close this bug
Comment 11 Shenfeng Liu 2012-11-07 08:55:59 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.