Issue 119755 - [From Symphony]star and symbol shape in ppt changed after openning by AOO
[From Symphony]star and symbol shape in ppt changed after openning by AOO
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: editing
3.4.0
PC All
: P2 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 03:10 UTC by Li Feng Wang
Modified: 2012-12-26 07:34 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file with shape (71.50 KB, application/vnd.ms-powerpoint)
2012-06-05 03:10 UTC, Li Feng Wang
no flags Details
UT file for this issue (16.00 KB, application/vnd.ms-powerpoint)
2012-07-30 07:19 UTC, Jianyuan Li
no flags Details
Patch for this issue (17.19 KB, patch)
2012-07-31 07:59 UTC, Jianyuan Li
lijianyuan1983: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-06-05 03:10:48 UTC
Created attachment 77963 [details]
sample file with shape

build:
AOO3.4 r1327774

steps:
1)open sample ppt file with AOO3.4
2)check shape and compare with MS Office

defect:
star and symbol shape is different from MS Office
Comment 1 Jianyuan Li 2012-07-30 02:26:51 UTC
I am working on this issue......
Comment 2 Jianyuan Li 2012-07-30 07:18:17 UTC
Root Cause:
Ellipse ribbon is imported as ribbon.
Resolution:
1. Create a new custom shape ellipse ribbon
2. Adjust custom shape structure member(sal_Int16 -> sal_Int32) to adapt ellipse ribbon guide formula parameters(32768).
Comment 3 Jianyuan Li 2012-07-30 07:19:19 UTC
Created attachment 78774 [details]
UT file for this issue
Comment 4 Jianyuan Li 2012-07-31 07:59:43 UTC
Created attachment 78788 [details]
Patch for this issue
Comment 5 Armin Le Grand 2012-08-01 09:02:55 UTC
ALG: I see the addition of two custom shape geometries which Sven Jacobi marked as todo, this looks great.
Why the change of the parameters from sal_Int16 to sal_Int32? I could not find a urgent reason for it. Is it just because it is often used as sal_Int32 anyways?
Comment 6 Jianyuan Li 2012-08-01 12:26:18 UTC
@Armin:
No, this is a must change. In mso_sptEllipseRibbonCalc and mso_sptEllipseRibbon2Calc, you can see a parameter with value 32768 which cannot be contained by sal_Int16. It will become as -32768. And this will result in an incorrect drawing result.
Comment 7 Armin Le Grand 2012-08-01 13:53:57 UTC
ALG @Jianyuan Li: Thanks for the explanation, I see now. Okay, some more checking, but looks good...
Comment 8 SVN Robot 2012-08-01 14:45:46 UTC
"alg" committed SVN revision 1368033 into trunk:
#119755# A new custom shape ellipse ribbon is added and usedPatch by: Jianyua...
Comment 9 Jianyuan Li 2012-08-17 03:05:18 UTC
The issue has been fixed
Comment 10 louqle 2012-08-20 03:18:04 UTC
verified on XP SP3 and Ubuntu 12.04 against trunk build 1374181
Comment 11 louqle 2012-08-23 00:58:43 UTC
verified in xp, Ubuntu, win7,mac,win7-64,Vista,suse,redhat, SLED 11 SP1 64 bit, all pass. Close this bug.