Issue 119940 - Document thumbnails not shown in Windows file manager
Summary: Document thumbnails not shown in Windows file manager
Status: CONFIRMED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 3.4.0
Hardware: PC All
: P3 Normal with 8 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: regression
: 121593 (view as issue list)
Depends on:
Blocks:
 
Reported: 2012-06-10 19:18 UTC by Andrea Pescetti
Modified: 2013-06-28 03:19 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
3.3.0 on Vista: thumbnails OK (101.50 KB, image/jpeg)
2012-06-10 19:18 UTC, Andrea Pescetti
no flags Details
3.4.0 on Windows 7: thumbnails missing (147.90 KB, image/jpeg)
2012-06-10 19:22 UTC, Andrea Pescetti
no flags Details
78218: 3.3.0 on Vista: thumbnails OK (61.17 KB, image/jpeg)
2012-06-10 19:22 UTC, Andrea Pescetti
no flags Details
picture (67.45 KB, application/x-rar-compressed)
2012-06-12 07:21 UTC, Du Jing
no flags Details
CCleaner report with fresh AOO3.4 install (93.20 KB, image/png)
2013-06-28 01:29 UTC, das_1971
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Andrea Pescetti 2012-06-10 19:18:11 UTC
Created attachment 78218 [details]
3.3.0 on Vista: thumbnails OK

The Windows integration of OpenOffice 3.4.0 apparently has a regression with respect to 3.3.0: the document thumbnails (preview?) are shown in version 3.3.0 while they are not shown in 3.4.0.

See attached:
- A screenshot of 3.3.0 on Vista (where the thumbnails are reportedly shown in version 3.4.0 too) where the thumbnails are OK
- A screenshot of 3.4.0 on Windows 7 (where the thumbnails are not shown, at least in folders different from the Desktop, and any icon size results in the OpenOffice icon being displayed instead of the thumbnails)

If confirmed, this is a regression.

[Bug discussion: Hawake, Gianluca Turconi, Sarah Hilditch on the Italian mailing list]
Comment 1 Andrea Pescetti 2012-06-10 19:22:01 UTC
Created attachment 78219 [details]
3.4.0 on Windows 7: thumbnails missing
Comment 2 Andrea Pescetti 2012-06-10 19:22:35 UTC
Created attachment 78220 [details]
78218: 3.3.0 on Vista: thumbnails OK
Comment 3 Ariel Constenla-Haile 2012-06-10 20:03:21 UTC
(In reply to comment #0)
> - A screenshot of 3.3.0 on Vista 
> - A screenshot of 3.4.0 on Windows 7

did you try *both* OOo/AOO version on *both* Windows version?
It could be that the problem is not with the OOo/AOO version, but with the Windows version: for example, thumbnails in Windows 7 may not work
Comment 4 Andrea Pescetti 2012-06-10 21:44:11 UTC
This is why the bug is opened as unconfirmed... We've seen it reported multiple times, indeed something is not working as expected, but we don't have "before and after" screenshots on the same system.

Anyway, apparently thumbnails do work correctly on Windows 7 limited to the Desktop and they don't work in other folders (but again, this might be a regression, or merely a Windows 7 setting...)
Comment 5 Du Jing 2012-06-12 07:21:06 UTC
Created attachment 78253 [details]
picture
Comment 6 Du Jing 2012-06-12 07:23:14 UTC
 I can't reproduce in win7 32bit.
 Thumbnails in OO3.3(Build:9567) and AOO3.4(1327774) all works well
Comment 7 Andrea Pescetti 2012-07-01 12:23:15 UTC
We did receive reports that this indeed happens during the 3.3 -> 3.4 upgrade. Now checking if recreating the user profile solves it.
Comment 8 Andrea Pescetti 2012-07-08 14:03:04 UTC
It is not solved by recreating the user profile. So, to restate what we know about the problem after discussing it extensively on the mailing lists in Italian:

- On Windows 7 (64 bits) at least, document thumbnails work in OpenOffice.org 3.3

- On the same system, updating to 3.4 leads to disappearing thumbnails (the ODF icons are shown instead)

- Reinstalling or resetting the profile does not solve the problem.
Comment 9 das_1971 2012-07-31 02:00:58 UTC
I'm experiencing the same problem but have zeroed in a little bit more. Currently I'm running two computers, one a laptop with 32bit Win 7, the other a PC with 64bit Win7, and keep identicle files on both by simple transfer using a flash drive. However, I'm only experiencing the problem on the 64bit PC. Now both computers were updated from OO 3.3 to 3.4 at the same time with no documents updated during this time. Did some footwork and here's what I found. (also please not I keep most my working files on the desktop)
On the 64bit win7 PC 
 - Documents originally saved on 3.3 still show their thumbnail. If in a folder, they still show a preview in the preview window.
 - Documents saved with AOO 3.4 no longer show either Thumbnail, now replaced with generic icon, and show an error on preview.
 - If the 3.3 Documents are moved into a folder, they keep their thumbnail and preview
 - If 3.3 Documents are copied (on the same machine) instead of a move, they lose the thumbnail, again being replaced by an icon, however can still be previewed properly. 

On the 32bin win7 machine
 - Documents saved on 3.3 still have thumbnail, and show a preview if view in a folder.
 - Moving 3.3 documents in and out of folders, copying, or opening them with 3.4 (NOT SAVING) has NO effect on thumbnails or preview
 - Documents saved using AOO 3.4 still retain a thumbnail, it is updated to fit the document, however they no longer can be previewed while in a folder.

Now concerning documents being transfered, this is where things get more interesting.
Concerning 3.3 documents
 - Documents transfered FROM the 64bit TO the 32bit are uneffected. They still retain thumbnail and preview
 - Documents transfered FROM the 32bit TO the 64bit lose their thumbnail (for an icon), but retain the preview function. Note: this is consistant with the items being copied within the 64bit machine, as they are essentially copied from the flash drive whether you use a move function or a copy function.
 - Transfering a 3.3 doc FROM the 32 bit TO the 64bit, subsiquently losing its thumbnail image, and transfering it BACK to the 32 rebuilds the thumbanil (no more generic icon).

Finally, concerning AOO 3.4 documents
 - Docs transfered FROM the 64 bit TO the 32 bit comp will have a thumbnail built upon being copied over to the 32bit. Note again consistant with how the 32bit copies files.
 - Documents sent FROM the 32 bit TO the 64 bit will lose the thumbnail.
 - These effects happen regardless of which machine they were saved on, I tested both.

Its a lenghty all over check, but I think I got it narrowed down pretty well. 
- Theres two seperate issues, one being the thumbnail/icon and the other being the preview.
- The preview (using the folders document preview version) doesn't function at all with AOO 3.4 saved documents and the error reffers to "an error in the Microsoft Previewer"
- As far the tumbnails error, it seems to only occur when windows 7 with AOO 3.4 has to build a thumbnail for a copied or saved file. I would assume the coding for this function within 3.4 for 64bit systems is either missing or errored.
I hope this info helps.
Comment 10 yunfei duan 2012-09-28 02:35:47 UTC
first it just a thought of mine I try both Windows XP and Vista and the thumbnails work well under both windows version by using the same OOo 3.4 next i try the same thing but only change the version to 3.3 and it works well too so i think it maybe just happen in Win7 and you can try to enter some thing in the document then save to see what happened or back to the directory and enter again sometimes it just to need refresh it
Comment 11 Andrew McDonald 2012-09-28 16:59:47 UTC
I also see this problem after upgrading from 3.3 to 3.4.1 on Windows 7 Ultimate x64 SP1. Calc spreadsheets which I've not re-saved still display thumbnails in Windows Explorer. New documents and older ones I've re-saved since upgrading only display the icon.

Perhaps the shell extension is checking some version number incorrectly and bailing out of the thumbnail generation code?
Comment 12 Alexander 2013-01-19 20:42:54 UTC
*** Issue 121593 has been marked as a duplicate of this issue. ***
Comment 13 tobydjones 2013-02-08 14:50:07 UTC
I have gone back to 3.3.0 (from 3.4.1) because I had no icons (windows7 x64).
When I reverted, my folder of odt docs instantly showed icons instead of a generic oo icon.
I won't be updating until this is fixed.
Comment 14 family-guy 2013-02-28 13:40:11 UTC
I can confirm this bug on Windows 8 64bit (openoffice 3.4.1).

I can generate the thumbnails opening the folder with openoffice documents from the "open" dialog in openoffice, after that the thumbnails are shown also in windows explorer.
Comment 15 dennbeau 2013-04-18 19:47:47 UTC
*** This issue has been confirmed by popular vote. ***
Comment 16 glenngingold 2013-04-25 23:23:07 UTC
I am not a computer expert. What I report is my observation only. I am able to see thumbnails using Windows 8. However, when I disable the AMD vision control center the thumbnails disappear. This is reproducible. This all through for Windows seven also.
Comment 17 das_1971 2013-06-28 01:29:38 UTC
Created attachment 80929 [details]
CCleaner report with fresh AOO3.4 install
Comment 18 das_1971 2013-06-28 02:14:44 UTC
- Fixed -
So after a day of googling and regediting, found the issue. And I'd bet that everyone having the problem runs CCleaner, so I'm including that in the fix. 

First the Fix(with CCleaner):
*If you have CCleaner set to run on start up or automatically, turn that off.* Rerun your installer for AOO 3.4 (If you don't have it, download the current version), and select repair or do a new install if needed. Either way, as soon as its done, you should have your icons back. yay. Now be safe and do a restart.
With your system back up, run CCleaner and do a registration scan and you should come up with something similar to the pic I uploaded "CCleaner report with fresh AOO3.4 install", showing missing dlls in 6 keys, 4 for \shlxthdl_x64.dll and one each for \ooofilt_x64.dll and \propertydl_x64.dll. The error is in the '_x64' extension to the base file's name, since those files are no longer included in AOO install, but their 32bit versions are. To fix it so you can use CCleaner again, you will have to either add them to the ignore list in CCleaner, or go to the individual reg key and deleting just the '_x64" from those file names. If your not familiar with reg editing, just add them to CC's ignore list. If your OCD like me, you've already started fixing them. Now just for example, your be taking "...program\shlxthdl\shlxthdl_x64.dll" and changing it to "...program\shlxthdl\shlxthdl.dll" within the registry key. And by the way, DO NOT RENAME THE DLL INSTEAD! honestly I have no idea if this will hurt or not, but just don't...

Fix without CCleaner:
If for some reason you have this error and do not have CCleaner, its still fixable. Just download the current version of AOO installer, run a repair, and you should be set. If you want to shore up your registry, your going to need to run regedit. If your not familiar with regediting, don't. If you are, dive on in and search do a search for these dll's individually: shlxthdl_x64, ooofilt_x64, propertyhdl_x64. there should be 4 InprocServer keys for shlx and 1 for the other two each. for each entry, remove the "_x64" portion from the string. Then you should be all set.

So what happened
When the Apache team made the leap from 3.3 to 3.4, they did some cut and paste programing. 3.3 contained both 32 and 64 bit versions of the 3 fixed dlls, appropriately titled "blah.dll" for 32bit and "blah_x64.dll" for 64bit. Now if you do some googling, you'll find that, in particular, shlxthdl_x64.dll had a nasty case of fighting with the explorer and locking up. So AOO wisely removed the 64 bit versions, apparently. However, they forgot to rename the extension for their registration keys.
Now this is fine since 64bit windows has a nice way of compensating for missing 64bit dll's but dropping down to their 32bit versions (may not be quoted perfect, I'm not a windows expert. It works tho). While this works for windows, CCleaner not so much, and buy deleting the registry keys, it will then later try to delete the dll's.

That should fix the thumbnail/icon issues, however it still doesn't fix the preview pane issue. I'm still working on that but it appears to be something left out of the newer version of OO3.4, as the old 3.3 files were previewed through MSWord without a problem, and 3.4 appear corrupt.
Comment 19 das_1971 2013-06-28 03:19:06 UTC
!Correction! Comment 18 is only a temp fix. As soon as you save a file it goes back to the old icon. Below is a permanent fix.

To get AOO 3.4 working you need to have access to the missing dll's. Easiest way to do this is to download an installer for OO 3.3 (I keep old versions in my downloads folder for things like this.)
Reinstall 3.3 on your comp. Now I recommend putting it in its base location and that's where I'll be referring to it from. If you want to put it in another, just use a search option to find your file by name.
Open up the folder at:
C:\Program Files (x86)\OpenOffice.org 3\Basis\program\shlxthdl\
you should have a few .dll files in here. Make copy's of the following:
ooofilt_x64.dll
propertyhdl_x64.dll
shlxthdl_x64.dll
Once you got those stored in a safe place, go ahead and reinstall AOO 3.4. After the install, return to the handler folder at:
C:\Program Files (x86)\OpenOffice.org 3\Basis\program\shlxthdl\
Paste your files, and you should be ready to go. 

Notes: This still doesn't fix the preview pane issues, and again I'm not sure that's fixable currently. This also makes CCleaner happy so no issues there. The one warning I have is that some people have reported shlxthdl_x64 causing issues with I believe iexplorer.exe (google it...) I didn't have any issues, but I'm not on your computer. This fix worked for me and I hope it works your you guys too.
Sorry again about the second post. Moved on to the preview pane issue without completely testing the first fix. My bad