Issue 119987 - [Crash]Application crash when paste texts under "Outline" view.
Summary: [Crash]Application crash when paste texts under "Outline" view.
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: editing (show other issues)
Version: 3.4.0
Hardware: All All
: P2 Critical (vote)
Target Milestone: 3.4.1
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-14 05:57 UTC by WangZhe
Modified: 2012-07-02 06:37 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 3.4.1_release_blocker+


Attachments
Code fix patch (382 bytes, patch)
2012-06-14 06:17 UTC, WangZhe
hdu: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description WangZhe 2012-06-14 05:57:51 UTC
1. Launch AOO3.4 then new a Writer and Presentation document.
2. Input some text into Writer document then copy them.
3. Switch to Presentation document then switch to "Outline" view.
4. Press F5(Play screen show),press Esc(Exit screen show).
5. Press Ctrl+V.
6. Application crash
Comment 1 WangZhe 2012-06-14 06:17:37 UTC
Created attachment 78317 [details]
Code fix patch

1. Root Cause:
When Presentation begins screen show,  function in Outline View Shell will be restored and removed. 
This can make the outline view shell can't response to some operation when playing screen show.
But when screen show finish, the function doesn't come back.
Then do some operation using this function will lead application crash.
2. Resolution:
Restore the function when screen show go to then end.
Comment 2 Yan Ji 2012-06-14 08:14:37 UTC
The problem can be reproduced against AOO 3.4
Comment 3 hdu@apache.org 2012-06-19 11:23:54 UTC
Excellent. Thanks for the find, for the analysis and for the patch! As a crash for a typical user interaction this problem should be considered as AOO 3.4.1 candidate.
Applied the fix as revision 1351653. Tested on our OSX build.
Comment 4 Li Feng Wang 2012-06-26 06:26:52 UTC
no crash with build r1351712(trunk).
and not fix in AOO3.4.1 branch.
Comment 5 jsc 2012-06-27 14:35:47 UTC
set release blocker flag for 3.4.1
Comment 6 hdu@apache.org 2012-06-27 14:56:07 UTC
Also merged into the AOO34 release branch as revision 1354554.
Comment 7 Terry Yang 2012-07-02 06:37:39 UTC
Verify fixed on AOO3.4.1 branch r1354891
Close this bug