Issue 119992 - [From Symphony] There is a memory leak in function ContentInfo::ContentInfo
[From Symphony] There is a memory leak in function ContentInfo::ContentInfo
Status: CLOSED FIXED
Product: performance
Classification: Code
Component: www
AOO 3.4.0
All All
: P3 normal (vote)
: AOO 4.0
Assigned To: zhang jianfang
:
Depends on:
Blocks: 120975 121366
  Show dependency treegraph
 
Reported: 2012-06-14 17:40 UTC by ChaoHuang
Modified: 2013-02-16 09:21 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
for file "main/editeng/source/editeng/editobj.cxx" (471 bytes, patch)
2012-06-14 18:30 UTC, ChaoHuang
chao.dev.h: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description ChaoHuang 2012-06-14 17:40:49 UTC
Steps to reproduce the issue
1) Launch Aoo3.4
2) New a ods file
3) Input some text in a cell with grammar error, like "asdasd"
4) Save the ods file
5) Close the ods file

Defect : There is a memory leak in function ContentInfo::ContentInfo
Comment 1 ChaoHuang 2012-06-14 18:29:46 UTC
The pWrong is simply set to value NULL, which ignored that it may be cloned from copied data. Need to release the non-empty pWrong before set it to NULL.
Comment 2 ChaoHuang 2012-06-14 18:30:14 UTC
Created attachment 78331 [details]
for file "main/editeng/source/editeng/editobj.cxx"
Comment 3 zhang jianfang 2012-06-18 14:04:58 UTC
Take over to commit the fix code.
Comment 4 zhang jianfang 2012-06-18 14:16:30 UTC
committed to trunk by revision 1351355.
Comment 5 ChaoHuang 2012-10-17 08:10:54 UTC
Suggest to put it into AOO 3.5.0 release
Comment 6 Yan Ji 2012-11-30 04:47:12 UTC
Since last SVT(r1400866) shows there is no memory leak, so close this defect as resolved.