Issue 120023 - [Regression]Copy and Paste from OO Text doc to Spreadsheet on OO V3.4
[Regression]Copy and Paste from OO Text doc to Spreadsheet on OO V3.4
Product: Writer
Classification: Application
Component: editing
PC Windows 7
: P3 Normal (vote)
: 4.0.0
Assigned To: Oliver-Rainer Wittmann
Depends on:
  Show dependency treegraph
Reported: 2012-06-18 16:30 UTC by Doug Atkinson
Modified: 2013-07-04 08:51 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 4.0.0_release_blocker+

sample ODT and ODS files (37.58 KB, application/x-zip-compressed)
2012-06-18 16:30 UTC, Doug Atkinson
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Doug Atkinson 2012-06-18 16:30:12 UTC
Created attachment 78383 [details]
sample ODT and ODS files

Open the attached ODT text file
Highlight one entire line of text using mouse and Hit Ctl C to copy to clip board
open the attached ODS file
Position cursor over any line which has contents on the line below it and Click mouse to select point for entry (first field on that line)
Hit Ctl V to paste the text line into the spread sheet.
The problem is that as well as pasting the desired data the contents of the line below are erased. 
I also tried this by just highlighting the one line I want to change on the ODS file but no difference in the above. 
Cut and paste using only one field of the text line seems to work but select any two adjacent fields in the test file and get the issue. 
Cutting ans pasting between line in the ODS file seems to work as expected with no erasure of the next line.
Perhaps there is some configuration I need to set???

I have done this for many years with as I remember it OO V3.0 but this morning immediately after updating to OO V3.4 the above problem happens.

I use this spreadsheet to track the food I eat from a number of text based data files so 99% of what I do is copy and paste.

This is intolerable and I am going to try to go back to a prior version of OO.

This happens with other text and ODS files not just the samples provided.
Comment 1 Yan Ji 2012-06-19 04:31:44 UTC
It's a regression defect since OO 3.3 release. I simplified the reproduce step as:
1. New a Writer doc
2. Insert a 4*4 table
3. Input content in each cell
4. Select all the cell in 2nd line and copy the content
5. New a calc doc
6. Input content in cell A1: D7
7. Select the whole row B
8. Paste what copied from writer

Defect: the content in row C has been erased

There is no such problem in OO 3.3
Comment 2 Doug Atkinson 2013-05-30 14:14:52 UTC
I understand that you have limited resources to resolve issues. It has been 11 months since you confirmed the bug and I assumed it had been fixed by now so I downloaded and installed 3.4.1 only to fined it had not. It is time consuming and a pain to keep uninstalling and reinstalling the old version. Would you please email me when this issue is resolved. This is absolutely critical to me as I used this method/function extensively.
Comment 3 Oliver-Rainer Wittmann 2013-06-19 11:40:47 UTC
working on a fix
Comment 4 Oliver-Rainer Wittmann 2013-06-19 13:19:50 UTC
Investigation reveals that the defect has been introduced in OOo 3.4 Beta by the RTF filter refactoring.
Comment 5 Oliver-Rainer Wittmann 2013-06-19 14:19:16 UTC
fixed on trunk for AOO 4.0 - revision 1494636
Comment 6 jsc 2013-07-02 12:04:41 UTC
grant showstopper flag, already fixed
Comment 7 fanyuzhen 2013-07-04 08:50:30 UTC
It is verified fixed in AOO 4.0 - revision 14946361496831

During reproducing on 3.4.1 and verifying on 4.0, I find there are some typo in original steps, here is the correction:

6. Input content in cells A1: D7(it's not necessary to input content in all cells, just input content in cells of row 1 is enough)
7. Select the whole column A
8. Paste what copied from writer

Defect: all cell's content in row 2 has been erased
Comment 8 fanyuzhen 2013-07-04 08:51:30 UTC
It is verified fixed in AOO 4.0 - revision 1496831