Issue 120067 - If the typed date is in 18th century, the output comes date-1
Summary: If the typed date is in 18th century, the output comes date-1
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: 3.4.0
Hardware: All All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo
Depends on:
Reported: 2012-06-23 14:47 UTC by Jukka R
Modified: 2012-08-31 09:02 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description Jukka R 2012-06-23 14:47:46 UTC
using O-O 3.3 I found the following bug:
Type e.g an century date like March 11. 1778 (1778-03-11), and you get output 1778-03-10 , and 1790-03-01 becomes 1790-02-28. But 17th century dates, e.g. 1678-03-01 give correct outputs. Not so funny!
  Jukka R
Comment 1 Regina Henschel 2012-06-23 15:20:08 UTC
I cannot confirm it with AOO3.4.

Please try entering dates with the newly released AOO3.4

Please try entering dates with setting the locale to English (UK).

Please specify your operating system.
Comment 2 Regina Henschel 2012-06-23 15:22:06 UTC
not UK but USA
Comment 3 Rob Weir 2012-06-23 22:54:03 UTC
I tried with OOo 3.3.0, Windows XP, en_US locale.  I was not able to get the bug to show up.

I tried both YYYY-MM-DD input as well as US-style MM/DD/YYYY

But the original report sounds plausible enough (leap year calculation?).

Is anyone able to reproduce?

Comment 4 Yan Ji 2012-06-26 08:12:43 UTC
It's a strange problem, I can reproduce problem in two Windows 7 environment but cannot reproduce it on other environment. I'll do further investigate on it.
Comment 5 Terry Yang 2012-08-31 09:02:30 UTC
I have try it on Win7 machine.
First my OS time zone as UTC+8:00 time zone beijing time, this issue will repro.

Then i close AOO and quickstarter, I change  OS time zone as UTC time zone London time, this issue can't repro.

So this maybe related current OS time zone.

Change bug to confirm status.