Issue 120099 - While a number is larger than 2 to the power of 48,it will return incorrect result while compare with adjacent number in formula.
Summary: While a number is larger than 2 to the power of 48,it will return incorrect r...
Status: CLOSED DUPLICATE of issue 96872
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: 3.4.0
Hardware: All All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-26 08:53 UTC by Shan Zhu
Modified: 2012-08-29 16:30 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Shan Zhu 2012-06-26 08:53:51 UTC
Build info: AOO3.4.1_r1351960

Steps:
1. Create a Spreadsheet file.
2. Input a number which is larger than 2^48 (281474976710656) into A1. 
   Say, 281474976710657.
3. Input a adjacent number into A2. Say, 281474976710656.
4. Write a formula to compare the two numbers. Such as, "=A2-A1". or "=A2>A1". 

Issue:
The two number will be regarded as equal numbers.
A2-A1 will return 0, and A2>A1 will return FALSE.
Comment 1 Shan Zhu 2012-08-29 09:00:39 UTC
Reproduced on AOO350m19610. Confirmed.
Comment 2 Regina Henschel 2012-08-29 16:30:04 UTC
That has been discussed very often. There is the task bug 69749 "Consolidate precision of binary representation and decimal rounding" and the bug 96872 "Bug in calculation, formula "=(n+1)-n" (where n >= 2^48) gives 0 as result". See in addition bug 69798 with comment from ooo@erack.de.

*** This issue has been marked as a duplicate of issue 96872 ***