Issue 120140 - [From Symphony]After doc file saved by AOO, one more section is created
[From Symphony]After doc file saved by AOO, one more section is created
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: save-export
3.4.0
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 06:35 UTC by Yan Ji
Modified: 2012-10-10 06:38 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (26.50 KB, application/msword)
2012-07-02 06:35 UTC, Yan Ji
no flags Details
patch to fix issues in 120140 (3.43 KB, patch)
2012-07-03 06:05 UTC, yuanlin
yuanlin.ibm: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-07-02 06:35:23 UTC
Created attachment 78540 [details]
sample

Build: AOO 3.4
Steps:
1. Load sample file
2. Save it as another doc file
3. Reload the saved file

Defect A more column section is added and a more paragraph is added to the first column
Comment 1 yuanlin 2012-07-03 05:55:19 UTC
Root cause:
Compared with the file AOO saved and MS Word 2003/2010 saved, there are two issues when saving the sample file in AOO.
1. When insert a column break after a paragraph end, both column break and paragraph end are exported. Only column break is needed to export.
2. When insert a section/page break after a section end, both of the break and end character are exported. Only section/page break is needed to export.

Resolution:
1. When insert a column break after a paragraph end, replace the paragraph end character with the column break but not add the break after paragraph end.
2. When insert a section/page break after a section end, do not export the section end character.
Comment 2 yuanlin 2012-07-03 06:05:31 UTC
Created attachment 78557 [details]
patch to fix issues in 120140
Comment 3 Jian Hong Cheng 2012-07-09 08:33:07 UTC
Code Review Done and Committed with Revision:1358968
Comment 4 Du Jing 2012-08-21 02:21:48 UTC
verified on the AOO3.5_r1374181
Comment 5 Shenfeng Liu 2012-10-10 06:38:15 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.