Issue 120205 - Indexing of bookmark references
Summary: Indexing of bookmark references
Status: CLOSED DUPLICATE of issue 24250
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 3.4.0
Hardware: PC Windows Vista
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-06 00:18 UTC by Will Pittenger
Modified: 2017-05-20 10:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Will Pittenger 2012-07-06 00:18:56 UTC
I'm working on a large (100+ pages) Writer document where we have a glossary which bookmarks for each entry.  Then every time the document references that term, we inserted a bookmark reference.  Now I'm adding an alphabetical index.  Writer is having problems automatically detecting instances of those terms.  It sees plain text term references just fine.  But not those using the bookmark references.  This is proving to be a real pain in the neck.

Can this be fixed anytime soon?  You will note I already asked in the forums: http://user.services.openoffice.org/en/forum/viewtopic.php?f=7&t=54893.
Comment 1 Will Pittenger 2012-07-06 00:21:32 UTC
I should explain what I'm seeing better.  When I manually attempt to insert a index entry using Insert/Index Entry with a bookmark reference selected, it shows the text of the bookmark.  But when I press Insert in the dialog, nothing happens.  I think the code in Writer that looks for instances of the term doesn't look at the text inside the bookmark reference.  Just plain text.  This seems to be what the Find dialog does.
Comment 2 Will Pittenger 2012-07-06 11:29:56 UTC
I didn't see Bug 24250 when I created this.  Sorry.

*** This issue has been marked as a duplicate of issue 24250 ***