Issue 120233 - [From Symphony] characters at the beginning of each lines in shape are lost when loading the sample ppt in AOO
[From Symphony] characters at the beginning of each lines in shape are lost w...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: open-import
3.4.0
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 05:54 UTC by liuping
Modified: 2012-12-26 08:26 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (59.00 KB, application/vnd.ms-powerpoint)
2012-07-10 05:54 UTC, liuping
no flags Details
capture.png (263.10 KB, image/png)
2012-07-10 05:56 UTC, liuping
no flags Details
patch for ppt import bullet size error (2.65 KB, patch)
2012-07-13 07:09 UTC, SunYing
sunyingshadesun: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description liuping 2012-07-10 05:54:15 UTC
Created attachment 78608 [details]
sample file

1.open the sample file
2.check the content of .ppt in AOO compared with open in MS

Defect:
characters at the beginning of each lines in shape are lost when loading the sample ppt in AOO

pls refer the capture.png
Comment 1 liuping 2012-07-10 05:56:11 UTC
Created attachment 78609 [details]
capture.png
Comment 2 SunYing 2012-07-10 06:07:03 UTC
I'm checking this defect.
Comment 3 SunYing 2012-07-13 02:27:31 UTC
 Root Cause:
AOO has not process the bulletsize value is -4000 to -1  which specified the absolute value specifies the bullet font size in points.
Comment 4 SunYing 2012-07-13 07:08:34 UTC
Solution:
support the situation.
add function to calculate the bullet relative size according font height and bullet absolute size.
Comment 5 SunYing 2012-07-13 07:09:49 UTC
Created attachment 78635 [details]
patch for ppt import bullet size error
Comment 6 SVN Robot 2012-07-20 02:11:03 UTC
"leidb" committed SVN revision 1363625 into trunk:
#120233# fix ppt import bullet size errorReported by: liu ping tan Patch by: ...
Comment 7 Lei Debin 2012-07-20 02:13:21 UTC
Good work, thx for the patch.
Comment 8 liuping 2012-08-20 06:07:52 UTC
Verified pass on Windows7, Redhat 32bit,Mac with AOO trunk r1374181