Issue 120344 - The line spacing of the paragraphs is incorrectly if open the .ppt doc
The line spacing of the paragraphs is incorrectly if open the .ppt doc
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: ui
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: WangZhe
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 02:05 UTC by Ma Bingbing
Modified: 2013-07-12 14:21 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (100.00 KB, application/vnd.ms-powerpoint)
2012-07-23 02:05 UTC, Ma Bingbing
no flags Details
Fix patch for this issue (1.86 KB, patch)
2012-07-24 02:06 UTC, Ma Bingbing
jiazema: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Ma Bingbing 2012-07-23 02:05:07 UTC
Created attachment 78702 [details]
sample file

1. Open the sample file with AOO
2. The line space between text is changed.
Comment 1 Li Feng Wang 2012-07-23 02:16:32 UTC
Can reproduce with AOO trunk r1362376 on Windows XP.
Comment 2 Regina Henschel 2012-07-23 22:43:52 UTC
The line spacing is set to fixed in Powerpoint, but the value "fixed" does not exist in Impress but only for Writer and Writer-frames, but not for shapes or textboxes.
The surrogate "at least" uses the maximum of font size and given value. So here the font size is 18pt and the value is 10pt, so line space 18pt is used.

Issue 15927 tells, that line space "fixed" has been added, but I still do not see it.

This is not specific for presentation, but a general missing feature or bug in the edit engine. The feature request for it is already in issue 16345.
Comment 3 Ma Bingbing 2012-07-24 02:06:08 UTC
Created attachment 78711 [details]
Fix patch for this issue

when the line space is "fixed", we should reset the text height and max ascent of the line.
Comment 4 Regina Henschel 2012-07-25 10:25:48 UTC
If I understand it right, you do not fully implement the property value "fixed". Why not?
Comment 5 Andre 2012-07-27 07:11:52 UTC
@Ma Bingbing: I have the same question as Regina, why only fix the symptoms and not the root cause?  How much more work would that be?

Can you explain your fix a little bit more to make the review easier?


Just for your convenience, the links to the issues mentioned above are bug 15927 and bug 16345 (Apache Bugzilla only recognizes an issue id when prefixed with the word "bug").
Comment 6 Ma Bingbing 2012-07-27 09:53:11 UTC
The reason of this patch is that somebody may meet the same issue, and they can use this function normally before fully implementing the property value "fixed".
(bug 15927 and bug 16345 were created several years, but not make headway now)

Moreover, I will spend time to research and resolve this problem, but I don't know how much i need. Thanks for your sharing knowledge which let me know more details about the problem.
Comment 7 Andre 2012-07-27 14:55:23 UTC
I have tested the patch but the code is never reached (with the test document).

@Ma Bingbing: Can you check that the attached test document and patch work on your side?
Comment 8 Ma Bingbing 2012-07-30 02:39:32 UTC
I had checked it before I submitted this patch, and I also ask someone to verify it. I will re-check it on latest version, but AOO build has build break now, so I will do that later.
Comment 9 Ma Bingbing 2012-08-02 07:01:16 UTC
@Andre: I check the patch on version 1367879, full build, then build the module editeng and filter as debug mode, the code can be reached and the patch works.
Comment 10 WangZhe 2012-09-07 03:36:02 UTC
I'll take this one
Comment 11 WangZhe 2012-09-07 05:15:13 UTC
Deliver At revision: 1381875
Comment 12 binguo 2012-11-16 06:11:17 UTC
Verified on Aoo_Trunk_20121109.1800 Rev.1407366
pass
Comment 13 binguo 2012-11-16 06:12:17 UTC
close it.