Issue 120381 - Viewing any document shows that all words need correction. This condition was not present the last time I saved the document
Summary: Viewing any document shows that all words need correction. This condition wa...
Status: CLOSED DUPLICATE of issue 121930
Alias: None
Product: Writer
Classification: Application
Component: viewing (show other issues)
Version: 3.4.0
Hardware: PC Windows XP
: P3 Major with 4 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-26 18:34 UTC by Dan Reisdorfer
Modified: 2017-05-20 10:13 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 4.0.0_release_blocker-


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Dan Reisdorfer 2012-07-26 18:34:05 UTC
To Whom It May Concern: 
I just opened up several OpenOffice Swriter documents-.odt (a second one, only after the first one was completely opened and then so on) and they all show that every word is needing correction-a red squiggly line underneath.  When I went up to Tools, Spelling and Grammar, the suggestions look like Spanish words, even though it states that my document's Text language is "English".  

What could have caused this kind of bug to occur?  I've never seen this happen in the past, and I've been working with and using OpenOffice documents for many years now.  

I was working on and edited one of the documents early this morning and last night too and it looked fine and the Spell Checker function worked fine-showed English as Text Language and showed English word choices. The save date shows 7/26/2012 04:53 AM, another document has not been edited/modified since June 22, 2012 and another one has not been edited/modified since June 11, 2012.  Although I have opened and reviewed each of these documents in the days since they were last Saved and they always came up with no problems or errors.

The only thing that I did differently this afternoon, was that I opened them up while a scan was running for the program Malwarebytes (I usually let all my scans-AV, SW, etc. completely finish before opening any documents). 

Could that have caused the dictionary function to crash, get scrambled or whatever has happened?  When I go to Tools, Options and then go over to Language Settings, Writing Aids it shows the Hunspell SpellChecker, the Libhyphen Hyphenator and the OpenOffice.org New Thesaurus. When I click on Edit, it shows that they are supposed to be the English Language versions.  
Any suggestions on things to try? 
I am applying for a job and I need these documents.
Thanks, 
Dan
Comment 1 Dan Reisdorfer 2012-08-10 06:35:41 UTC
To Whom It May Concern: 
Additionally, I uninstalled the 3.4 version completely (including folders in Program Files) and then reinstalled a new 3.4 version from the OO web site—sadly the problem still exists.  
Any suggestions on things to try? 
I am applying for a job and I need these documents now.
Thanks, 
Dan
Comment 2 J White 2012-10-27 16:28:36 UTC
I have the identical problem which occurred immediately after allowing an update from v.3.3 to v. 3.4.  The update blew away my previous open files which I wanted to be restored, and now any file I open or create (writer or calc) wants every word to be corrected!

THIS IS A MAJOR BUG IN THE 3.4 RELEASE, AND A CRITICAL PROBLEM THAT NEEDS IMMEDIATE ATTENTION! This is a Show-stopper, as it corrupts a previously working version without the ability to restore functionality. 

Please stop pushing 3.4 out until this bug is fixed and provide a work around  to restore the previous version. 

There needs to be a patch or work-around available to get back to a working 3.3 level until this bug can be fixed!


I have tried uninstalling 3.4, reinstalling 3.3 and a clean install of 3.4 to no avail - no dictionary (using default English dictionary) is recognized. System restore does not affect the problem on either version.  

System Info:  Acer laptop, Windows 7, I-3 64 bit processor - previous Open Office release 3.3, (may have had open files to be restored after logging off before installing 3.4)

Sincerely,

Jim White
Comment 3 Ariel Constenla-Haile 2012-10-27 17:04:58 UTC
Please read the release notes:

http://www.openoffice.org/development/releases/3.4.1.html#AOO3.4.1ReleaseNotes-KnownIssues

Apache OpenOffice 3.4.0 and 3.4.1 manage the user profile differently than previous versions. The old user profile is automatically converted so that users can keep their extensions and settings. In a minority of cases, especially with highly customized profiles (many extensions or customizations) the conversion doesn't succeed. Common symptoms are: frequent application crashes, problems with dictionaries or thesaurus, OpenOffice starting and crashing after a few seconds. To solve this, just reset/rename your user profile as explained in the official OpenOffice forum. http://user.services.openoffice.org/en/forum/viewtopic.php?t=12426

Before renaming/removing the whole user profile, as explained in the link, please try the following:

- shutdown OpenOffice, including the system tray quickstarter (on windows 7 it may be hidden on the right bottom corner)
- remove the extensions folder in the user profile:

C:\Users\ariel\AppData\Roaming\OpenOffice.org\3\user\extensions\
C:\Users\ariel\AppData\Roaming\OpenOffice.org\3\user\uno_packages\

- Start OpenOffice
Comment 4 Dan Reisdorfer 2013-03-11 06:50:37 UTC
Ariel: 
I've tried all of the things you and your link stated that i try and I actually have worse problems now.  In addition to the original problems listed, now my std dictionary is not functioning for real time spellcheck or working when I go up to the drop down menu and click on spellcheck. There has to be an simpler and more effective way to get AOO working again, properly.  
This problem situation needs to be the highest priority, otherwise I will be forced to letting everyone that I originally convinced to switch over to AOO and prior to the Oracle sale just OO, and anyone else who'll listen, that AOO is not a viable option any longer.
Comment 5 Guy I Colby IV 2013-04-03 22:44:19 UTC
This happened to me today.  All of my Open Office documents now unexpectedly show every word underlined in red, which basically renders the spellcheck feature worthless.  I use Open Office primarily as a straightforward word processor, and I have never even used the Options menu.  I am not very familiar with computer jargon, and much of the discussion on this issue is way over my head.  As far as I know, I have done nothing which might have caused this, but I surely would like for someone to explain, in easily understood terms, how to fix it.

Thanks,

Guy I. Colby IV
Comment 6 B. Jerew 2013-04-04 12:44:09 UTC
Thank you for posting this. I had also attempted to reinstall AOOo with no improvement. i deleted the two folders you mentioned in this posting and opened up my last document. before was all red, but now seems to have returned to normal after AOOo rebuilt those two folders. Will see how this works out.

Thanks again.
-b

"There's no such thing as a fool-proof system. Someone will make a better fool tomorrow."
(In reply to comment #3)
> Please read the release notes:
> 
> http://www.openoffice.org/development/releases/3.4.1.html#AOO3.4.
> 1ReleaseNotes-KnownIssues
> 
> Apache OpenOffice 3.4.0 and 3.4.1 manage the user profile differently than
> previous versions. The old user profile is automatically converted so that
> users can keep their extensions and settings. In a minority of cases,
> especially with highly customized profiles (many extensions or
> customizations) the conversion doesn't succeed. Common symptoms are:
> frequent application crashes, problems with dictionaries or thesaurus,
> OpenOffice starting and crashing after a few seconds. To solve this, just
> reset/rename your user profile as explained in the official OpenOffice
> forum. http://user.services.openoffice.org/en/forum/viewtopic.php?t=12426
> 
> Before renaming/removing the whole user profile, as explained in the link,
> please try the following:
> 
> - shutdown OpenOffice, including the system tray quickstarter (on windows 7
> it may be hidden on the right bottom corner)
> - remove the extensions folder in the user profile:
> 
> C:\Users\ariel\AppData\Roaming\OpenOffice.org\3\user\extensions\
> C:\Users\ariel\AppData\Roaming\OpenOffice.org\3\user\uno_packages\
> 
> - Start OpenOffice
Comment 7 B. Jerew 2013-04-04 12:44:37 UTC
*** This issue has been confirmed by popular vote. ***
Comment 8 jsc 2013-07-02 15:47:39 UTC
remove showstopper request because we think it will be fixed with AOO 4.0 and I see no chance that anybody has time investigate further in this issue.

If a solution comes up in the next days I will grant the showstopper flag again
Comment 9 Andrea Pescetti 2013-07-02 20:42:48 UTC
Even though some users here report that the solution in the Release Notes
https://issues.apache.org/ooo/show_bug.cgi?id=120381#c3
worked for them and some didn't, this definitely seems the problem mentioned in the Release Notes.

Affected users should choose NOT to migrate personal settings from OpenOffice 3 when the OpenOffice 4 installation asks for it. This will build a clean user profile, that won't be affected by the problem.
Comment 10 Guy I Colby IV 2013-09-18 18:15:46 UTC
(In reply to jsc from comment #8)
> remove showstopper request because we think it will be fixed with AOO 4.0
> and I see no chance that anybody has time investigate further in this issue.
> If a solution comes up in the next days I will grant the showstopper flag
> again

I am the person who originally posted comment #5 on this bug.  As you indicated, the problem did go away after I downloaded Open Office 4.0, and everything was fine for awhile.  However, the exact same problem has now recurred; every word in all my Open Office documents is now underlined in red, and my spellcheck dictionary seems to have almost completely disappeared.  This is a real disaster for me, since I rely on spellcheck heavily due to poor typing skills.  Please, is there a simple, easy to understand fix for this?  As I indicated in my original comment, most of the jargon in the postings on this bug is way over my head.

Thanks,

Guy I. Colby IV
Comment 11 B. Jerew 2013-09-19 20:32:20 UTC
Guy-
Don't worry about all the jargon, just go back to the instructions in Ariel's post [#3] and delete the two folders. The next time you start OpenOffice, it will rebuild those two folders on its own. Simple!

1- close all openoffice windows and the quickstarter
2- delete two folders
3- start openoffice
4- [optional] be happy :)

-Ben
"There is no such thing as a fool-proof system. Someone will make a better fool, tomorrow." @LoneWolffe

(In reply to Guy I Colby IV from comment #10)
> (In reply to jsc from comment #8)
> > remove showstopper request because we think it will be fixed with AOO 4.0
> > and I see no chance that anybody has time investigate further in this issue.
> > If a solution comes up in the next days I will grant the showstopper flag
> > again
> 
> I am the person who originally posted comment #5 on this bug.  As you
> indicated, the problem did go away after I downloaded Open Office 4.0, and
> everything was fine for awhile.  However, the exact same problem has now
> recurred; every word in all my Open Office documents is now underlined in
> red, and my spellcheck dictionary seems to have almost completely
> disappeared.  This is a real disaster for me, since I rely on spellcheck
> heavily due to poor typing skills.  Please, is there a simple, easy to
> understand fix for this?  As I indicated in my original comment, most of the
> jargon in the postings on this bug is way over my head.
> 
> Thanks,
> 
> Guy I. Colby IV
Comment 12 sandalwood 2013-11-14 12:08:14 UTC
I also find that the spell checker has suddenly become non-functional, with all words (with odd exceptions like "and") getting the red squiggly underline.  Would reinstalling Open office help?
Comment 13 B. Jerew 2013-11-14 12:29:24 UTC
For now, the solution seems to be to follow the steps in Comment #3. Reinstalling doesn't remove the personal files.

Interestingly, I also had the same problem occur some time after the latest upgrade to AOO 4.0.1, but as because of upgrading.

(In reply to sandalwood from comment #12)
> I also find that the spell checker has suddenly become non-functional, with
> all words (with odd exceptions like "and") getting the red squiggly
> underline.  Would reinstalling Open office help?
Comment 14 Rainer Bielefeld 2014-01-05 08:09:33 UTC
I close this one, what does not mean that I do not believe that the problems did occur for some users, but that I think we can't fix this one.

Currently we have at least 2 types of problems mixed here:

(a) Spell check does not work from beginning, see
    <http://www.openoffice.org/development/releases/3.4.1.html#AOO3.4.>
(b) Spell Check stopped working without known reasons
    "Bug 123853 - Spell Check stops working" and may be others

Closing as DUP of "Bug 121930 - Tracking Issue for 3.4.1 Spell Correction Not Working" because original report seems to be concerning (a)

@Commenters:
Please check what problem (a)  or (b) you have and whether you can contribute new information to "Bug 123853" or "Bug 121930" (or to others for different problems)

*** This issue has been marked as a duplicate of issue 121930 ***