Issue 120456 - Hang on loading encrypted .odt
Summary: Hang on loading encrypted .odt
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 3.4.0
Hardware: All All
: P3 Normal (vote)
Target Milestone: 3.4.1
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-03 14:01 UTC by Andre
Modified: 2013-07-11 14:59 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 3.4.1_release_blocker+


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andre 2012-08-03 14:01:11 UTC
Office hangs when I load an encrypted .odt.
Comment 1 Andre 2012-08-03 14:06:07 UTC
Problem is connected with the Base64 encoder/decoder in main/packages/.  When I change ManifestImport.cxx and ManifestExport.cxx to use sax::Convertex for Base64 encoding/decoding the bug goes away.
Comment 2 SVN Robot 2012-08-03 14:08:51 UTC
"af" committed SVN revision 1368968 into branches/AOO34:
#i120456# Replace Base64 encoder/decoder with the one from sax.
Comment 3 SVN Robot 2012-08-03 17:35:07 UTC
"jsc" committed SVN revision 1369110 into branches/AOO34:
#120456# remove obj from makefile"Patch By: arielchReview By: jsc
Comment 4 jsc 2012-08-03 18:26:08 UTC
set release blocker flag
Comment 5 SVN Robot 2012-08-03 19:13:06 UTC
"jsc" committed SVN revision 1369168 into trunk:
#120456# merge fix from AOO34 branch
Comment 6 SVN Robot 2012-08-05 07:56:08 UTC
"af" committed SVN revision 1369534 into trunk:
#i120456# Apply patch from AOO34 branch:
Comment 7 Li Feng Wang 2012-08-06 05:49:06 UTC
Not reproduce with AOo341 r1367911 on Windows XP.

Make odt with open password and edit password. not hange when I load it.

Andre, Can you provide more info or sample file?
Comment 8 Li Feng Wang 2012-08-07 03:29:17 UTC
Password is not recognized on Linux 64bit only. 
Is this defect same as reopened problem in Bug 120385?
Comment 9 Li Feng Wang 2012-08-09 03:09:56 UTC
Can't reproduce on Mac, Windows XP, Win7 32bit, Redhat 32bit, Redhat 64bit with AOO341 r1369843.