Issue 120464 - AOO 3.4.1: Printing with multiple pages - only the first page is printed
Summary: AOO 3.4.1: Printing with multiple pages - only the first page is printed
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: printing (show other issues)
Version: 3.4.0
Hardware: PC Windows 7
: P3 Major (vote)
Target Milestone: 3.4.1
Assignee: Oliver-Rainer Wittmann
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-05 12:35 UTC by Oliver Brinzing
Modified: 2012-11-14 07:33 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 3.4.1_release_blocker+


Attachments
test document (68.53 KB, application/vnd.oasis.opendocument.text)
2012-08-05 12:35 UTC, Oliver Brinzing
no flags Details
Klarinettenblatt_pdf_creator.pdf (43.52 KB, text/html)
2012-08-05 12:37 UTC, Oliver Brinzing
no flags Details
Klarinettenblatt_adobe_pdf.pdf (70.92 KB, text/html)
2012-08-05 12:38 UTC, Oliver Brinzing
no flags Details
Klarinettenblatt_aoo340_pdf_creator.pdf (68.11 KB, text/html)
2012-08-05 12:38 UTC, Oliver Brinzing
no flags Details
Printing issue (103.30 KB, application/postscript)
2012-08-05 12:56 UTC, jolatt
no flags Details
patch to solve this defect (422 bytes, patch)
2012-08-06 08:45 UTC, Oliver-Rainer Wittmann
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Oliver Brinzing 2012-08-05 12:35:59 UTC
Created attachment 78846 [details]
test document

printing attached *.odt doc prints only the first page
confirmed with: win 7 64bit aoo 3.4.1 rev1367911
with aoo 3.4 printing works fine.
Comment 1 Oliver Brinzing 2012-08-05 12:37:25 UTC
Created attachment 78847 [details]
Klarinettenblatt_pdf_creator.pdf
Comment 2 Oliver Brinzing 2012-08-05 12:38:15 UTC
Created attachment 78848 [details]
Klarinettenblatt_adobe_pdf.pdf
Comment 3 Oliver Brinzing 2012-08-05 12:38:43 UTC
Created attachment 78849 [details]
Klarinettenblatt_aoo340_pdf_creator.pdf
Comment 4 jolatt 2012-08-05 12:56:20 UTC
Created attachment 78850 [details]
Printing issue
Comment 5 jolatt 2012-08-05 13:06:09 UTC
Same with Ubuntu 12.04.
Comment 6 Regina Henschel 2012-08-05 14:40:24 UTC
I have tried it with my debug build of r139534 (that is from trunk, not from branch 3.4.1) on WinXP. Printing with "Microsoft Office Document Image Writer" results in four pages, but text is only on the first page and the other three pages are empty.

And I get three times the error message
Error: data should have been created already in getRendererCount... From File c:/AOO_2012_08_git/trunk/main/sw/source/ui/uno/unotxdoc.cxx at Line 3104
Comment 7 Regina Henschel 2012-08-05 15:01:17 UTC
revision r1369534, sorry.
Comment 8 Shenfeng Liu 2012-08-05 15:45:46 UTC
3.4.1 release blocker candidate if it is a regression.
Comment 9 jsc 2012-08-06 05:34:55 UTC
I can't reproduce it with a built on revision 1369110 from the AOO34 branch on MacOS.

I can load the document and can print it with all 4 pages
Comment 10 Oliver-Rainer Wittmann 2012-08-06 08:14:31 UTC
I can confirm the defect with my local AOO 3.4.1 build on rev. 1369110, with AOO 3.4.1 dev.snapshots on rev. 1367911 and on rev. 1354891 and on my local trunk developer environment on Windows 7.

It looks like that my fix for bug 119189 causes with issue.
Comment 11 Oliver Brinzing 2012-08-06 08:39:34 UTC
> It looks like that my fix for bug 119189 causes with issue.

if i print direct (without using the writer print dialog) it works.
but as far as i open the print dialog, only the first page is printed
can you confirm ?
Comment 12 Oliver-Rainer Wittmann 2012-08-06 08:44:07 UTC
(In reply to comment #11)
> > It looks like that my fix for bug 119189 causes with issue.
> 
> if i print direct (without using the writer print dialog) it works.
> but as far as i open the print dialog, only the first page is printed
> can you confirm ?

Yes, I can confirm this in my environment.
Comment 13 Oliver-Rainer Wittmann 2012-08-06 08:45:22 UTC
Created attachment 78855 [details]
patch to solve this defect
Comment 14 jsc 2012-08-06 08:46:23 UTC
set release blocker flag for 3.4.1
Comment 15 SVN Robot 2012-08-06 09:19:22 UTC
"orw" committed SVN revision 1369754 into trunk:
#120464# - method <PrinterController::triggerAppToFreeResources()>: reset <La...
Comment 16 SVN Robot 2012-08-06 09:26:07 UTC
"orw" committed SVN revision 1369757 into branches/AOO34:
#120464# - method <PrinterController::triggerAppToFreeResources()>: reset <La...
Comment 17 Oliver-Rainer Wittmann 2012-08-06 09:27:26 UTC
fixed on trunk and on AOO34 branch
Comment 18 jsc 2012-08-06 10:43:00 UTC
set flag again
Comment 19 Oliver Brinzing 2012-08-07 11:03:16 UTC
seems to be fixed in rev1369843
cannot reproduce now with win 7 64bit / xp 32bit
Comment 20 jolatt 2012-08-07 13:25:18 UTC
with Ubuntu 12.04 64bit, the bug sill exists
Comment 21 jolatt 2012-08-07 13:27:58 UTC
(In reply to comment #20)
> with Ubuntu 12.04 64bit, the bug sill exists

revision 1369843
Comment 22 jsc 2012-08-07 14:37:02 UTC
I can't reproduce this with the latest builds based on 1369843. I have no physical printer but I was able to print a multiple pages document into a postscript file.
Comment 23 jolatt 2012-08-07 15:31:39 UTC
Because of another reason, I had to restore the home directory of Ubuntu. After this I tried it again and it now works.
Sorry.
Comment 24 binguo 2012-11-14 07:32:48 UTC
Verified on Aoo_Trunk_20121109.1800 rev 1407366
multiple pages document can be printed correctly, no matter how to trigger print task, click print button directly OR print from print dialog.
so the bug is fixed.
Comment 25 binguo 2012-11-14 07:33:10 UTC
Close it.