Issue 120582 - [From Symphony] import of Microsoft Word document: indent of certain paragraphs in list is wrong
[From Symphony] import of Microsoft Word document: indent of certain paragrap...
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: open-import
3.4.0
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Oliver-Rainer Wittmann
: ms_interoperability
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 10:21 UTC by Oliver-Rainer Wittmann
Modified: 2012-12-26 08:48 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample document to reproduce the described defect (30.00 KB, application/octet-stream)
2012-08-15 10:21 UTC, Oliver-Rainer Wittmann
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Oliver-Rainer Wittmann 2012-08-15 10:21:41 UTC
Created attachment 78966 [details]
sample document to reproduce the described defect

defect:
- import the attached sample Microsoft Word document which is in Microsoft Word binary file format.
--> the left indent and the first line indent of the first and the third list item is wrong compared to Microsoft Word.

root cause:
the paragraph which have the wrong left and first line indent in AOO have set an addition right indent. Because internally in AOO the left, first line and right indent are combined into one attribute, the indent value from the list style is not applied to these paragraphs.
Comment 1 Oliver-Rainer Wittmann 2012-08-15 10:23:59 UTC
fix is in progress.

defect occurs at least since OOo 3.1
Comment 2 SVN Robot 2012-08-15 10:56:23 UTC
"orw" committed SVN revision 1373328 into trunk:
#120582# - method <SyncIndentWithList(..)>: consider the case that a right in...
Comment 3 Oliver-Rainer Wittmann 2012-08-15 10:56:48 UTC
fixed on trunk
Comment 4 Du Jing 2012-08-28 03:33:39 UTC
verified on the build r1377620
Comment 5 Oliver-Rainer Wittmann 2012-08-30 07:22:08 UTC
indicating in the summary that the original bug report and fix are from Symphony.