Issue 120650 - the slide content corrupt when open in Aoo
Summary: the slide content corrupt when open in Aoo
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: formatting (show other issues)
Version: 4.0.0-dev
Hardware: All All
: P3 Normal (vote)
Target Milestone: ---
Assignee: WangZhe
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-22 03:07 UTC by Tang Meng
Modified: 2012-11-08 01:38 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
sample file (674.70 KB, application/x-zip-compressed)
2012-08-22 03:13 UTC, Tang Meng
no flags Details
sample file (80.50 KB, application/x-zip-compressed)
2012-08-22 04:49 UTC, Tang Meng
no flags Details
patch (520 bytes, patch)
2012-08-23 08:30 UTC, Tang Meng
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Tang Meng 2012-08-22 03:07:07 UTC
When you open sample files in Aoo, it can't display normally.
Comment 1 Tang Meng 2012-08-22 03:13:31 UTC
Created attachment 79049 [details]
sample file
Comment 2 Tang Meng 2012-08-22 04:49:40 UTC
Created attachment 79054 [details]
sample file

sample file
Comment 3 Li Feng Wang 2012-08-22 05:28:55 UTC
Can reproduce with AOo trunk r1374181.
Comment 4 Tang Meng 2012-08-22 05:29:54 UTC
I am looking at this bug.
Comment 5 Tang Meng 2012-08-23 08:30:30 UTC
Created attachment 79095 [details]
patch

1. Root Cause:
This is caused by the very huge bullet size:4283%. The maximum bullet size in Aoo is 250%, and in MSPPT is 400%.
And in MSPPT2007, if the bullet size lager than 400%, it will treat it as 100%. I propose to handle the bullet size as MSPPT2007 does.

2. Resolution:
Through Aoo UI, the bullet relative size has the range [1~250], so the file must be damaged, we should check the size and set it to a normal value during loading odp files.
Comment 6 SVN Robot 2012-09-06 12:41:32 UTC
"alg" committed SVN revision 1381583 into trunk:
#120650# truncate mis-sized bullet sizes to useful valuesPatch by: Tang MengR...
Comment 7 WangZhe 2012-09-07 04:43:43 UTC
I'll take this one
Comment 8 WangZhe 2012-09-07 05:40:48 UTC
Delivered by SVN Robot at revision 1381583
Comment 9 louqle 2012-11-08 01:38:14 UTC
verified on Win7, Mac 10.7, suse 11 sp1 against build 1404513, fixed