Issue 120682 - With Open Office 3.4.0., close doc x button disappears when 2 Calc files simultaneously open
Summary: With Open Office 3.4.0., close doc x button disappears when 2 Calc files simu...
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Calc
Classification: Application
Component: viewing (show other issues)
Version: 3.4.0
Hardware: PC Windows, all
: P3 Minor (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needmoreinfo
Depends on:
Blocks:
 
Reported: 2012-08-23 11:14 UTC by GONON Yves
Modified: 2017-05-20 09:54 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description GONON Yves 2012-08-23 11:14:21 UTC
Since the recent installation of Open Office 3.4.0, when 2 different Open office.org Calc files are open simultaneously, (each file including 15 sheets being used to keep the financial accounts), the close doc button "x" disappears on the right of the taskbar (the one which is expected to close the active file only). This button is visible when only one file is open and disappears when opening the second file. The 3 buttons on the top right corner of the window  remain visible (to minimize the window, change its size or totally close Open Office.org) . Closing the soft with this last button leads to a message box telling that O.O was cled suddezntly and that both active files will be saved, and can be recovered when opening again Open Office.org Calc. The only way to get round of the issue is to click on  "window" in the taskbar and then on  "close the window", but this is less convenient. This did not occur with the former version of Open Office 3.
Comment 1 Oliver-Rainer Wittmann 2012-08-23 13:12:50 UTC
I think it is intended behavior that the button to close the document is only visible when one document is open.
I can see this feature already in OOo 3.0.
If more than one document is opened the general window close button can be used to close the window.

But your observation that using the general window close button for closing a document causing AOO 3.4 to crash, it not intended, of course.

I could not reproduce the crash on my Windows 7 with AOO 3.4 by opening just simple documents.

Can you reproduce it also with some simple small documents?
Can you reproduce it also with text documents, presentations or draw documents?
Would it be possible to share your documents?
Comment 2 Terry Yang 2012-08-29 09:44:16 UTC
Agree with Oliver, the close button visiable only when one document is open, this should by design behavior.

For crash issue, please upload the sample file to this bug.
Add keywords needmoreinfo for this bug.
Comment 3 Rob Weir 2013-03-21 19:43:59 UTC
Not a bug.