Issue 120837 - Update internal boost to version 1.48
Update internal boost to version 1.48
Status: CLOSED FIXED
Product: Build Tools
Classification: Code
Component: external prerequisites
4.0.0-dev
All All
: P3 major (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 22:52 UTC by Pedro Giffuni
Modified: 2013-07-11 12:41 UTC (History)
1 user (show)

See Also:
Issue Type: TASK
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Patch for updating boost to version 1.48 (49.56 KB, patch)
2012-09-06 22:52 UTC, Pedro Giffuni
no flags Details | Diff
Updated patch (116.24 KB, patch)
2012-09-07 16:12 UTC, Pedro Giffuni
no flags Details | Diff
Work in Progress but may even work. (100.72 KB, patch)
2012-09-12 22:46 UTC, Pedro Giffuni
no flags Details | Diff
Boost update. (110.12 KB, patch)
2012-09-15 04:41 UTC, Pedro Giffuni
no flags Details | Diff
Boost update (133.71 KB, patch)
2012-09-15 20:25 UTC, Pedro Giffuni
no flags Details | Diff
Boost update (cleaned up) (131.21 KB, patch)
2012-09-15 20:43 UTC, Pedro Giffuni
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Pedro Giffuni 2012-09-06 22:52:39 UTC
Created attachment 79325 [details]
Patch for updating boost to version 1.48

I have a preliminary patch to update boost and I also include the patches from FreeBSD's native port which is known to build with gcc 4.2.1 and clang 3.1.

FreeBSD uses Boost version 1.48 which offers better compatibility with newer compilers and in particular clang.

Testers are required for the Windows, linux and MacOS X builds.
Comment 1 zjchen 2012-09-07 08:02:39 UTC
I would like to help to check whether the patches work in Mac OS building environment.

A first attempt failed at applying boots_1_48_0.patch
I use command "git apply --check patch-boost" under main module. it returns me that "error: patch failed: boost/boost_1_48_0.patch:1".
also failed when using "patch -p0 -i patch-boost" to apply

should I create the boost_1_48_0.patch manually?
Comment 2 Pedro Giffuni 2012-09-07 16:12:44 UTC
Created attachment 79356 [details]
Updated patch

The previous diff didn't work because I used SVN mv for the base boost patch and svn diff didn't know it had to copy the old file first.

This new version should work fine. I also added more headers to the delivery list.
Comment 3 zjchen 2012-09-10 05:43:31 UTC
Thanks for you updated patch and reply:)

I have checked the updated patch on my Mac OSX 10.7 and Windows 7 build environment.
Both return me the break in canvas module when compiling main/canvas/source/null/null_spritecanvashelper.cxx

The break info is that
"
/trunk/main/solver/350/wntmsci12.pro/inc\boost/numeric/conversion/detail/numeric_cast_traits.hpp(10) : fatal error C1083: Cannot open include file: 'boost/numeric/conversion/detail/preprocessed/numeric_cast_traits.hpp': No such file or directory
dmake:  Error code 2, while making '../../wntmsci12.pro/slo/null_spritecanvashelper.obj'
"
Seems that the "preprocessed" directory is not generated in my boost header path under solver module.
Is this problem not existing on your FreeBSD environment?
Comment 4 Pedro Giffuni 2012-09-11 00:38:10 UTC
(In reply to comment #3)
...
> Seems that the "preprocessed" directory is not generated in my boost header
> path under solver module.
> Is this problem not existing on your FreeBSD environment?

Thank you for the report. I actually only made sure that the boost part builds and I didn't go far enough in the build. The problem is/was there are several "preprocessed" subdirectories that are missing in the file
main/boost/prj/d.lst

It is something easy to fix but it will take some time.
Comment 5 Pedro Giffuni 2012-09-12 22:46:53 UTC
Created attachment 79447 [details]
Work in Progress but may even work.
Comment 6 zjchen 2012-09-14 09:55:04 UTC
The patch does not deliver header files in main\solver\350\wntmsci12.pro\inc\boost\lambda, then cause the break in sc module when compiling sc\source\core\data\column3.cxx

column3.cxx:36 error: boost/lambda/bind.hpp: No such file or directory
column3.cxx:38 error: boost/lambda/lambda.hpp: No such file or directory
Comment 7 Pedro Giffuni 2012-09-14 18:47:50 UTC
(In reply to comment #6)
> The patch does not deliver header files in
> main\solver\350\wntmsci12.pro\inc\boost\lambda, then cause the break in sc
> module when compiling sc\source\core\data\column3.cxx
> 
> column3.cxx:36 error: boost/lambda/bind.hpp: No such file or directory
> column3.cxx:38 error: boost/lambda/lambda.hpp: No such file or directory

lambda/bind.hpp doesn't exist anymore. There is a 
bind/bind.hpp

There is a lambda/lamda.hpp though and it should be delivered.

I still have to complete the delivery list but this is all very strange: AOO builds using the external boost 1.48.
Comment 8 Pedro Giffuni 2012-09-14 19:03:57 UTC
(In reply to comment #6)
> The patch does not deliver header files in
> main\solver\350\wntmsci12.pro\inc\boost\lambda, then cause the break in sc
> module when compiling sc\source\core\data\column3.cxx
> 
> column3.cxx:36 error: boost/lambda/bind.hpp: No such file or directory
> column3.cxx:38 error: boost/lambda/lambda.hpp: No such file or directory

These headers were introduced by this commit:
http://svn.apache.org/viewvc?view=revision&revision=1381946
Comment 9 Pedro Giffuni 2012-09-15 04:41:53 UTC
Created attachment 79512 [details]
Boost update.

This patch completes the delivery of the headers. It should be complete but the process is error prone since I am human.

As noticed, some files might have disappeared or changed place.
Comment 10 Pedro Giffuni 2012-09-15 20:25:52 UTC
Created attachment 79517 [details]
Boost update

 r1381946 did a strange trick to deliver some extra headers used in #i120847#: attempt to follow the change with the newer boost too.
Comment 11 Pedro Giffuni 2012-09-15 20:43:55 UTC
Created attachment 79518 [details]
Boost update (cleaned up)
Comment 12 zjchen 2012-09-17 07:55:51 UTC
The patches build completely on my Win7 and MacOSX environment. It is OK for me:)
Comment 13 SVN Robot 2012-09-17 14:39:41 UTC
"pfg" committed SVN revision 1386635 into trunk:
#i120837# - Update internal boost to version 1.48Newer version of boost have ...
Comment 14 SVN Robot 2012-09-19 02:45:34 UTC
"pfg" committed SVN revision 1387438 into trunk:
#i120837# - Update internal boost to version 1.48.0Re-sort the patches: prese...
Comment 15 Pedro Giffuni 2012-09-22 03:47:36 UTC
There are some linking issues when building with -enable-dbgutil on Windows , but otherwise the update went well on all platforms.
Comment 16 Pedro Giffuni 2012-09-25 16:24:06 UTC
Issue in setup_native was fixed by orw in r1389287.