Issue 120857 - Define Range causes crash
Summary: Define Range causes crash
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: 3.4.1
Hardware: All All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact: Yurggent Alfredo Chable Torrez
Depends on:
Reported: 2012-09-08 23:44 UTC by Mario
Modified: 2013-08-09 14:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.0.0
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description Mario 2012-09-08 23:44:03 UTC
After marking a block and defining new range Calc seems to freeze.  Attempting to save the file results in a message that this is not possible while links are being updated.

In the attached file create a block of about 50 lines, an it will crash.

This happened on previous versions of oo.
Sept. 2012
Comment 1 Mario 2012-09-08 23:58:47 UTC
I have an attachment but your system will not accept it because of its size.
Please contact me when you need it.
Comment 2 LadyMariu 2013-02-09 20:23:15 UTC
There´s no attached file.

Will wait in case Mr. Mario will send it by mail.

So far I tried reproducing the bug on a new spreadsheet based on his comments but Calc did not freeze.

Tested on:
Win7 SP1 64bits (AOO 341m1 - B9593 - R 1372282)

Comment 3 Diego Valle Rosado 2013-04-25 01:25:09 UTC

I cheked this bug on Windows 7, using AOO 4.0 and this error does not occur,
whether it's possible to attach the exemple with just the neccesary to reproduce the error, it would be helpful.

Comment 4 Yurggent Alfredo Chable Torrez 2013-05-02 17:49:30 UTC
Hello i have tested this bug with W7 and AOO 4.0.0
and nothing happens and your attachment is not available.

you can upload it?

Yurggent Alfredo Chable Torrez
Comment 5 Yurggent Alfredo Chable Torrez 2013-05-08 22:23:55 UTC
only a screenshot with the error.
Comment 6 Yurggent Alfredo Chable Torrez 2013-06-11 22:49:01 UTC
I cheked this bug on Windows 7, using AOO 4.0 and this error does not occur
and I requested the file and did not receive anything.

Yurggent Alfredo Chable Torrez
Comment 7 Yurggent Alfredo Chable Torrez 2013-06-17 12:30:26 UTC
I reopened it because mario sent me the file.
This is a serious bug, I can't open the file and AOO 4.0 is chrash.

I'm not sure of the content, but if anyone need the file, contact me.
Comment 8 Yurggent Alfredo Chable Torrez 2013-06-17 12:33:51 UTC
AOO can not open the file and stays on hold, I had to restart my computer because it was crash.

verified with AOO 4.0 in the OS Windows 7 64 bits.
Comment 9 Yurggent Alfredo Chable Torrez 2013-06-17 13:00:21 UTC
after half an hour, this error message appears:

a scripting framework error ocurred while running the basic scrip

message; the following basic script could not found:
library: 'Standard'
module: 'Module1'
method: 'save'


Yurggent Alfredo Chable
Comment 10 Armin Le Grand 2013-06-18 11:37:46 UTC
ALG: So...if I want to check and evtl. debug, how do I get that file...?
Comment 11 Armin Le Grand 2013-06-19 15:36:41 UTC
ALG: Okay, got the file. Loading already for a while. Broke that, checked. Seems as if a lot of image links are added to that file, e.g. buffer = 0x0c7fc7d4 "". The time seems to be spent in the SFX_APP()->GetFilterMatcher().GuessFilter call in svx/source/unodraw/unoshap.cxx:1721.
Comment 12 Armin Le Grand 2013-06-19 16:59:27 UTC
ALG: The cntent file is 35mb, I still try to find a tool that can show it to me ;-) There seem to be *many* linked small graphics in this file (none locally added). Each one is tried to be downloaded, so that's where the time is spent. Each try takes some seconds and it's tried first at load time to detect the file type. Avoiding this step (can be done later when the objects are rendered) makes the document load rather normally; but after that when scrolling on 2nd tab and the images come into play, the same load tries happen and block the office. BTW: At load time and later the loading always fails in my environment, interestingly directly opening in a browser the one example given above works. Thus, may have to do with the SERF changes.
Comment 13 Armin Le Grand 2013-06-19 17:19:41 UTC
ALG: My test with loading the images later shows that the document has no error and is loaded correctly, not crashing. The crash may be due to mem constraints on the used machine. It will take veeeery long, but I can ensure that it will load when the ressources are there (quick check: loaded the mem set of AOO is roughly 280MB).
Thus, this task is not a crash but an enhancement request for more speed from my POV.
Comment 14 Armin Le Grand 2013-06-24 08:39:45 UTC
ALG: Adding comment Mario set directly to me:
Hi Armin,
I am Mario. I sent the problem file.  The graphics in the file have been pasted in incidentally.
I was totally unaware of their presence.  To load the file I reverted back to OO 2.2, which
did the trick just fine.
My biggest complaint is that when I define a new range name OO crashes
regardless of the version ( I didn’t try ver 1.1).
I have used this file on my old XP and now I use it on my new laptop.  So it isn’t a hardware issue.
After OO crashes the recovery module successfully recovers the file with the new range defined and working.
Thanks for your time, and if you have any questions I am only too pleased to help.
Comment 15 Armin Le Grand 2013-06-24 08:40:37 UTC
ALG: Adding comment Mario set directly to me:

Hi Again.
I have some good news.
I’ve chopped down the file a bit and now it sort of works.
The problem is that when a database range is defined in this file, it’s size affects
the length of time the define window stays open once the OK button is pressed.
In an attempt to make it go away the user then tries to close the popup window by pressing
the cross in the corner.  OO then appears to be unresponsive for a minute or so.  Attempts
at navigating the cursor results in no cell being highlighted, even though the values on the
input line change.  Finally OO terminates.
I am attaching the new file.
Comment 16 Armin Le Grand 2013-06-24 08:43:11 UTC
ALG: Hi Mario, thanks for the comments. Could you give a step-by-step description how *exactly* do this database range definition? Which menu/command/action do you use?
It will probably not happen in a nearly-empty new document, but evtl. it's possible to clode the dialog faster as it gets closed now.

Thanks in advance!