Issue 120864 - [From Symphony]Text is overlapped by the drawing object when open the .doc file
[From Symphony]Text is overlapped by the drawing object when open the .doc file
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: open-import
3.4.1
All All
: P3 normal (vote)
: 4.0.0
Assigned To: kang jane
: ms_interoperability
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 04:16 UTC by Yan Ji
Modified: 2012-10-10 06:51 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (328.00 KB, application/msword)
2012-09-10 04:16 UTC, Yan Ji
no flags Details
snapshot (4.17 KB, image/png)
2012-09-10 04:18 UTC, Yan Ji
no flags Details
Recalculate height for the case that couldn't get the right height at first caculation. (820 bytes, application/octet-stream)
2012-09-11 01:25 UTC, kang jane
kangjane2012: review?
Details

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-09-10 04:16:40 UTC
Created attachment 79365 [details]
sample

Build: AOO Trunk Rev r1377620
OS: All
Steps:
1. Open attached sample file
2. Go to page 4

Defect: Text is overlapped by drawing object.
Comment 1 Yan Ji 2012-09-10 04:18:16 UTC
Created attachment 79366 [details]
snapshot
Comment 2 kang jane 2012-09-11 01:25:32 UTC
Created attachment 79387 [details]
Recalculate height for the case that couldn't get the right height at first caculation.

Root cause:
In the special case, height couldn't be right calculated.

Solution:
Check if we can't get the correct height. If not, recalculate it.

UT:
1.Test with the sample file in the defect.
Comment 3 zhengfan 2012-09-11 09:02:41 UTC
I would like to take a look at the solution.
Comment 4 Jian Hong Cheng 2012-09-12 06:27:30 UTC
Reviewed and Committed with revision 1383798,thanks for the patch.
Comment 5 Du Jing 2012-09-20 06:42:35 UTC
verified on the AOO3.5_r1387482
Comment 6 Shenfeng Liu 2012-10-10 06:51:19 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.