Issue 120883 - AutoFilter in .XLS (MSO97): filter data lost when there are two sheets sharing the same data base range
Summary: AutoFilter in .XLS (MSO97): filter data lost when there are two sheets sharin...
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: 4.0.0-dev
Hardware: All All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: ms_interoperability, regression
Depends on:
Blocks: 121014
  Show dependency tree
Reported: 2012-09-11 07:56 UTC by louqle
Modified: 2014-03-10 12:05 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

sample file (15.50 KB, application/
2012-09-11 07:56 UTC, louqle
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description louqle 2012-09-11 07:56:18 UTC
Created attachment 79394 [details]
sample file

build: 1381968 

1. open the sample file
2. check the autofilter in sheet2

no data in the auto filter list except the three menus "Top 10"...

There are two sheets containing the same data

In sheet1 there is a custom filter for column B: less than 10

In sheet2 there is the filter for column B is Top 10

While the filter data in sheet2 lost...

This happens on both win7 64-bit, XP and suse 11 sp1

But this may be a regression since on my XP against build 1376366, it works fine.
Comment 1 Rainer Bielefeld 2013-08-30 04:33:50 UTC
Without understanding the details, i can CONFIRM reporter'sobervations  with  "AOO 4.1.0-Dev – English  UI / German locale - [AOO410m1(Build:9750)  -  Rev. 1516435  2013-08-24]" on German WIN7 Home Premium (64bit)", own separate user profile:

1. From AOO Start Center open reporter's sample document
2. InSsheet2.B1 click Autofilter  dropdown arrrow
   > Filter list appears
   Expected: Should show all values in column
   Actual: only shows "All", "Top 10". "Standard Filter"                  !!!
3. Continue, click 'Standard Filter'
   Expected: Filter Criteria dialog will open
   Actual: Nothing                                                        !!!

Additional info:
a) That still worked fine with server installation of  "AOO 3.4.1 – German UI / German locale [AOO341m1(Build:9593) - Rev.1372282]" on German WIN7 Home Premium (64bit)", own separate user profile. so REGRESSION

b) already broken in Rev. 1457992 (as expected due to report)

c) competitors: Works fine with LibO, Calligra, SoftMaker FreeOffice

d) I saved reporter's sample as Book2fromLibO4.ods, with that document 
   autofilter worked fine in AOO 4
e) I reopened Book2fromLibO4.ods with LibO and saved as Book2fromLibO4.xls
   Problem reappeared with AOO 4
Comment 2 Andre 2014-03-07 12:24:16 UTC
I saved the bug document with Excel (2013) to ODS and XSLX.  Loading these with AOO 4.1 (developer build) results in:
- ODS is loaded without any filter on sheet2
- XLSX is loaded currectly, i.e. filters on sheet2 exist and work as expected.
Comment 3 Andre 2014-03-10 12:05:17 UTC
Bug 120478 did not cause this issue but also did not fix it, because it targeted only OOXML, not the binary format of Excel.