Issue 121095 - All words recognized as misspelled
Summary: All words recognized as misspelled
Status: CLOSED DUPLICATE of issue 121930
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 3.4.1
Hardware: PC Windows 7
: P3 Major (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-24 20:54 UTC by K G
Modified: 2017-05-20 10:11 UTC (History)
16 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description K G 2012-09-24 20:54:54 UTC
Hardly any words that I type into my document are in the spellcheck dictionary, and they are all underscored, eventhough they are spelled correctly. I have to go and manually "Add to Dictionary" for every word I type in.
Comment 1 roswell 2012-09-26 05:22:34 UTC
My spell check suddenly stopped working.  It has no words, so it shows everything has been misspelled.  I have had to turn it off becuase it's become completely useless.
Comment 2 Jenny 2012-10-01 09:36:33 UTC
(In reply to comment #1)
> My spell check suddenly stopped working.  It has no words, so it shows
> everything has been misspelled.  I have had to turn it off becuase it's
> become completely useless.

I have the exact same problem , I have uninstalled and downloaded again but still nothing,  I have tried to install a dictionary extension but after I click add i the extension manager I am unable to find where to add it to and so can not install.   

This is extremely frustrating as I use OO for my college work and this has only become a problem since the update from version 3.3 to 3.4.1  Can anyone please help with this issue as currently OO is just another program taking up space on my pc
Comment 3 Muad'Dib 2012-12-19 05:09:58 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > My spell check suddenly stopped working.  It has no words, so it shows
> > everything has been misspelled.  I have had to turn it off becuase it's
> > become completely useless.
> 
> I have the exact same problem , I have uninstalled and downloaded again but
> still nothing,  I have tried to install a dictionary extension but after I
> click add i the extension manager I am unable to find where to add it to and
> so can not install.   
> 
> This is extremely frustrating as I use OO for my college work and this has
> only become a problem since the update from version 3.3 to 3.4.1  Can anyone
> please help with this issue as currently OO is just another program taking
> up space on my pc

I am experiencing the exact same problem as the other 3 people posting (I'm using US English). It seemed to begin when I upgraded from OO v3,3 to ApacheOO v3.4.0, and continues with AOO v3.4.1. There is a file named dict-en.oxt in the
\OpenOffice\OpenOffice.org3\share\extensions\install\
directory, but it doesn't act like it's being used. Unless a word is in my user-defined dictionary, it's treated as though it is misspelled.

I still have my old dictionary folder from v3.3, but moving it into a similar location in v3.4.0 or v3.4.1 does nothing.

Can someone clearly state which dictionary file should go into what folder to fix this problem?
Comment 4 Ariel Constenla-Haile 2012-12-19 05:36:12 UTC
(In reply to comment #3)
> Can someone clearly state which dictionary file should go into what folder
> to fix this problem?


try the procedure described in https://issues.apache.org/ooo/show_bug.cgi?id=121205#c1
Comment 5 Muad'Dib 2012-12-19 06:05:50 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Can someone clearly state which dictionary file should go into what folder
> > to fix this problem?
> 
> 
> try the procedure described in
> https://issues.apache.org/ooo/show_bug.cgi?id=121205#c1

Ariel, thanks - this seems to have worked (I tried the 'short version': simply removing (actually renaming, in case I needed them back) the 'uno_packages' and 'extensions' subdirectories.

BTW, for other users, if you don't have a subdirectory named 'administrator', simply look for the subdirectory with your current user name.

FYI, I had done no customization to OO or AOO other than adding custom words to my dictionary and creating one user-defined time format. So whatever the cause of the conversion problem from OO 3.3 to AOO 3.4, it was unlikely to have been caused by customizing (in fact until about a week ago, when I started to investigate the cause of this problem, I didn't even realize such customization was possible!).

Thanks again!
M`D
Comment 6 Muad'Dib 2012-12-19 06:07:44 UTC
One additional piece of info: Since the original post mentioned the platform was WIN7, I wanted to state that on this machine I'm using Windows XP Pro not WIN7.
Comment 7 Ariel Constenla-Haile 2013-01-13 21:46:34 UTC
*** Issue 121617 has been marked as a duplicate of this issue. ***
Comment 8 Ariel Constenla-Haile 2013-01-16 01:26:48 UTC
*** Issue 121628 has been marked as a duplicate of this issue. ***
Comment 9 Ariel Constenla-Haile 2013-01-16 19:35:48 UTC
*** Issue 121635 has been marked as a duplicate of this issue. ***
Comment 10 Ariel Constenla-Haile 2013-01-23 18:59:18 UTC
*** Issue 121661 has been marked as a duplicate of this issue. ***
Comment 11 Ariel Constenla-Haile 2013-01-23 19:00:17 UTC
*** Issue 121663 has been marked as a duplicate of this issue. ***
Comment 12 hchaess 2013-02-21 18:23:49 UTC
The spell checker does not check or note obviously erroneous spelled words. My platform is Vista.  This problem  recently surfaced.  I believe everything was working OK last month (jan 2013) but can not confirm.
Comment 13 Muad'Dib 2013-03-12 21:41:22 UTC
FYI, the problem reappeared even though I have done no update or reinstallation of AOO (I'm still running v3.4.1). Removing the uno_packages & extension folders again fixed things, but I wonder why the problem popped this time.
Comment 14 Rainer Bielefeld 2013-05-22 04:27:39 UTC
Related to "Bug 121930 - Tracking Issue for 3.4.1 Spell Correction Not Working" for now.
Comment 15 jerrie_l_mccreary 2014-02-26 11:51:57 UTC
 I was unable to recreate the bug for "All words recognized as misspelled"

1. I went into Open Office Writer 4.0.1

2. I typed a few paragraphs from a magazine in Open Office writer, I misspelled a few words on purpose.  If any of the words were misspelled there was a correct word for it in the word dictionary.  The only word the dictionary did not have an option for was U.s.  It did not pick up on the fact the lower s should be a capital S.

3. I did the same test in Microsoft word and did not get the bug to reproduce.

Evaluation:  With the updates in Open Office the chance that this issue would still be happening was very small
Comment 16 Nick Polimeni 2014-04-14 12:27:16 UTC
Suddenly the English spell checker stopped working. I haven't tested other languages, as I've gone through the wringer in just trying to figure out how to get it back working. Uninstalled everything, including  'unpack' folders, folders containing copies of download installations... to no avail. I can't confirm that it happened as a result of an upgrade. I know the version I have was working one day and stopped working at some unidentifiable moment. 

I cannot rule out Microsoft's Malicious software detector... most people simply have it on automatic upgrade... so I wouldn't have known if an upgrade caused the problem.
Comment 17 Edwin Sharp 2014-04-24 12:23:54 UTC
Can not reproduce
AOO420m1(Build:9800)  -  Rev. 1586681
Rev.1586681
Win 7
Comment 18 rvln 2014-07-13 18:07:21 UTC
I have the same 'problem': Correctly spelled words are marked as wrongly spelled and vice-versa. An additional phenomenon is that this behaviour previously occurred in Outlook 2011, which now spellchecks correctly. If I recall correctly it started after I downloaded a component update.
Comment 19 Ariel Constenla-Haile 2014-07-13 18:32:11 UTC
(In reply to rvln from comment #18)
> I have the same 'problem': Correctly spelled words are marked as wrongly
> spelled and vice-versa. An additional phenomenon is that this behaviour
> previously occurred in Outlook 2011, which now spellchecks correctly. If I
> recall correctly it started after I downloaded a component update.

Did you try to remove the folders \extensions and \uno_packages?
See bug 121205 comment 1
Comment 20 Ariel Constenla-Haile 2014-07-13 18:37:13 UTC
Marking as dup. in order to unify all the bugs about spell checking not working

*** This issue has been marked as a duplicate of issue 121930 ***