Issue 121215 - [From Symphony]Font name Arial in XLS is changed to Arial1 when save as .ods
[From Symphony]Font name Arial in XLS is changed to Arial1 when save as .ods
Status: CLOSED FIXED
Product: Calc
Classification: Application
Component: save-export
3.4.1
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 04:28 UTC by Yan Ji
Modified: 2013-07-12 12:24 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (14.00 KB, application/vnd.ms-excel)
2012-10-15 04:28 UTC, Yan Ji
no flags Details
patch for issue (1.31 KB, patch)
2012-10-15 04:59 UTC, Tan Li
hdu: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-10-15 04:28:09 UTC
Created attachment 79774 [details]
sample

Build: AOO 3.4.1
OS: All
Defect:
 Save attached .xls file to .ods, the cell's font name Arial is changed to Arial1 in style.xml
Comment 1 Tan Li 2012-10-15 04:58:26 UTC
I have a patch for this issue.

Root cause:
Font pitch is set PITCH_DONTKNOW for all FontFamily while construct font item. While some FontFamily has known pitch type. It will treat Arial with PITCH_DONTKNOW as new font from previou Arial font in document. 

Solution:
Set corresponding font pitch for FontFamily according to official literature to avoid mistake one font as two.
Comment 2 Tan Li 2012-10-15 04:59:35 UTC
Created attachment 79775 [details]
patch for issue
Comment 3 hdu@apache.org 2012-10-17 12:22:54 UTC
Comment on attachment 79775 [details]
patch for issue

That makes perfect sense. Thanks for analyzing and solving the problem!
Comment 4 SVN Robot 2012-10-17 12:39:39 UTC
"hdu" committed SVN revision 1399203 into trunk:
#i121215# fix the spreadsheet font family\n\nPatch-by: Tan Li <litan.test@gma...
Comment 5 hdu@apache.org 2013-07-12 12:24:52 UTC
Verified in AOO 4.0.0