Issue 121264 - XPropertyChangeListener does not get fired when changing properties
Summary: XPropertyChangeListener does not get fired when changing properties
Status: CLOSED DUPLICATE of issue 121263
Alias: None
Product: App Dev
Classification: Unclassified
Component: api (show other issues)
Version: 3.4.1
Hardware: PC Windows 7
: P3 Major
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-24 08:10 UTC by Jens Bornschein
Modified: 2012-10-24 22:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Jens Bornschein 2012-10-24 08:10:51 UTC
XPropertyChangeListener does not get fired when changing properties, e.g. of an XLayer. The web is full of threads for not using this listener because it doesn’t get fired at all, even on dispose. This could be linked to the bug 61522 which seems to be the same problem. The Events have to get fired on every changes made on the properties.


Sample code C#

    class DrawDocLayerManager : XPropertyChangeListener, XVetoableChangeListener, XPropertyStateChangeListener, XPropertySetInfoChangeListener, XPropertiesChangeListener 
    {       
        private readonly XNameAccess _layerManger;

        public DrawDocLayerManager(XLayerSupplier drwaDoc)
        {
            if (drwaDoc == null)
                throw new ArgumentNullException("drwaDoc", "The XLayerSupplier is null");

            _layerManger = drwaDoc.getLayerManager();
            XIndexAccess xIndexAccess = (XIndexAccess)_layerManger;

            //Add PropertychangeListener to all Layer
            for (int i = 0; i < xIndexAccess.getCount(); i++)
            {
                try
                {
                    XLayer xLayer = (XLayer)xIndexAccess.getByIndex(i).Value;

                    xLayer.addPropertyChangeListener("Name", this);
                    xLayer.addVetoableChangeListener("Name", this);
                    xLayer.addPropertyChangeListener("", this);
                    xLayer.addVetoableChangeListener("", this);

                    ((XPropertySet)xLayer).setPropertyValue("Name", new Any("foo"));

                }
                catch (System.Exception e)
                {
                    Console.WriteLine(e);
                }


            }


        }

        public void disposing(EventObject Source)
        {
             throw new NotImplementedException();
        }

        public void propertiesChange(PropertyChangeEvent[] aEvent)
        {
            throw new NotImplementedException();
        }

        public void propertySetInfoChange(PropertySetInfoChangeEvent evt)
        {
            throw new NotImplementedException();
        }

        public void propertyStateChange(PropertyStateChangeEvent aEvent)
        {
            throw new NotImplementedException();
        }

        public void vetoableChange(PropertyChangeEvent aEvent)
        {
            throw new NotImplementedException();
        }

        public void propertyChange(PropertyChangeEvent evt)
        {
            throw new NotImplementedException();
        }
    }
}
Comment 1 Marcus 2012-10-24 22:38:07 UTC
.

*** This issue has been marked as a duplicate of issue 121263 ***