Issue 121284 - Version Python 2.3.5 is an regression under MacOsX
Summary: Version Python 2.3.5 is an regression under MacOsX
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 3.4.1
Hardware: Mac OS X 10.8
: P3 Normal with 5 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-27 14:54 UTC by papayes
Modified: 2017-05-20 10:01 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 4.0.0_release_blocker-


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description papayes 2012-10-27 14:54:25 UTC
Hello,
under Microsoft Windows Vista or Win7, AOO 3.4.1 version 2.6.1. final.0 
as indicates the linguist extension 1.5.1 > Command : List all the words 

Under MacOsX, 10.8.2, AOO 3.4.1 use the language Python version 2.3.5 
it's a regression(dating 2005) .

Result: an extension as Grammalecte 2.3 does not install on MACOsX because written with a more recent version ( 2.6.1 ) even if this version is already old.

Why not to put same version of the language Python on quite version AOO, Windows or Mac?!)

No problem with LibO 357 (Windows or MacOsX) use Language Python 2.6.1 


To install linguist 1.5.1 : http://www.dicollecte.org/_misc/linguist-1.5.1.oxt

To try to install Grammalecte 2.3 : http://www.dicollecte.org/download/fr/Grammalecte-v0.2.3.oxt

Cordialy,
Comment 1 papayes 2012-11-30 10:54:46 UTC
hello,
To include Python 3.3 would facilitate the compatibility AOO / LibO, because it is the version which is already included in LibreOffice 4.
Comment 2 Pedro Giffuni 2012-11-30 22:01:58 UTC
(In reply to comment #0)
> Hello,
> under Microsoft Windows Vista or Win7, AOO 3.4.1 version 2.6.1. final.0 
> as indicates the linguist extension 1.5.1 > Command : List all the words 
> 
> Under MacOsX, 10.8.2, AOO 3.4.1 use the language Python version 2.3.5 
> it's a regression(dating 2005) .
> 

I don't have a MacOS X ( donations welcome ;) ) but my understanding is that we ship AOO with the system python and Apple is rather conservative when updating python.

We also happen to depend on the old development environment (gcc42) so we tend to use the older build system. That will be solved but it's quite a big project.
Comment 3 Pedro Giffuni 2012-11-30 22:13:08 UTC
(In reply to comment #1)
> hello,
> To include Python 3.3 would facilitate the compatibility AOO / LibO, because
> it is the version which is already included in LibreOffice 4.

Compatibility with OOo is more important than compatibility with LibreOffice.
Moving to Python3 involves breaking compatibility with all current OpenOffice releases. It's a bold move that I personally don't recommend. 

AOO 3.5 carries Python 2.7.3 which has some compatibility with 3.x and with some effort it is possible to have scripts run with both versions. It is a step in the right direction without causing havoc in the developer community.
Comment 4 jsc 2013-06-20 11:02:35 UTC
I can install the linguist-1.5.1.oxt extension on my local dev snapshot on MacOS. I see at least a new top level menu and don't know if it provides a toolbar as well. Potentially here is further problem with an incompatible change but that is a different issue and don't belong to Python.

I have Python 2.7.5 installed on my Mac and I am preparing the dev snaphots with this version as well.

Grammalecte-v0.2.3.oxt is not available to me!

I can't reproduce this, no showstopper for me