Issue 121428 - Incorrect Ascending Sort Using Basic
Summary: Incorrect Ascending Sort Using Basic
Status: CLOSED DUPLICATE of issue 97808
Alias: None
Product: Calc
Classification: Application
Component: programming (show other issues)
Version: 3.4.1
Hardware: PC Windows 7
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 121500
  Show dependency tree
 
Reported: 2012-12-02 05:41 UTC by Alan
Modified: 2017-05-20 09:53 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Alan 2012-12-02 05:41:42 UTC
I am writing a Basic macro and encountered an issue with the sort function while using the call oCells.Sort(sortProperties()). My locale is English, USA. For the sorts something pecular happens! The upper and lower case letters are incorrectly sorted but with a twist. The letters are in the correct order but upper and lower case order is REVERSED.

Example:
  Using the following names:
    Pring, Wes
    whitmer, Tony
    Whitmer, Tony
    rosario, Kerry
    Rosario, Kerry
    Stewart John

  A case sensitive ascending sort results in:
    Pring, Wes
    rosario, Kerry
    Rosario, Kerry
    Stewart John
    whitmer, Tony
    Whitmer, Tony

  A case sensitive descending sort results in:
    Whitmer, Tony
    whitmer, Tony
    Stewart John
    Rosario, Kerry
    rosario, Kerry
    Pring, Wes

These results are clearly wrong.

I have tried the above data using the menu sort and I get the same result! I copied the data from one spreadsheet to another new, empty spreadsheet (copying only text, no formats) and got the same result both from my Basic program sort and from the menu sort.
Comment 1 binguo 2012-12-21 09:58:10 UTC
Verified on Aoo_Trunk_20121214.1915 Rev.1413470, it occurs, confirm it.
Comment 2 oooforum (fr) 2015-02-20 10:09:11 UTC
Already reported

*** This issue has been marked as a duplicate of issue 97808 ***