Issue 121486 - Postcript level 3 is reset to level 2
Postcript level 3 is reset to level 2
Status: CLOSED FIXED
Product: ui
Classification: Code
Component: ui
AOO400-dev
All All
: P4 normal (vote)
: AOO 4.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-15 12:16 UTC by Andrea Pescetti
Modified: 2013-07-12 12:54 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: 3.4.1
Developer Difficulty: easy


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andrea Pescetti 2012-12-15 12:16:39 UTC
(As described by Pedro Giffuni in http://mail-archives.apache.org/mod_mbox/openoffice-dev/201212.mbox/%3C1355514993.22845.YahooMailNeo%40web113503.mail.gq1.yahoo.com%3E on the ooo-dev mailing list; includes solution)

The issue is: when setting up your printer you can define the Postscript level.
OO will give you the option to set it to "Postcript level 3" but after choosing
level 3 it will only set it to level 2.

To solve this go to file

main/padmin/source/rtsetup.src

Search for the string "PostScript Level 3" (line 167)

As you see after the semicolon there is a 3 which is also the value assigned
for Level 2. Change the 3 value to a 4.

compile, test and commit!
Comment 1 SVN Robot 2013-01-19 03:09:26 UTC
"pfg" committed SVN revision 1435482 into trunk:
i121486 - Postscript level 3 is always bogusly reset to level 2.
Comment 2 Pedro Giffuni 2013-01-19 03:11:01 UTC
I had the fix in my tree for a while and I verified it just works.