Issue 121589 - Writer should not underline trailing spaces in wrapped lines
Summary: Writer should not underline trailing spaces in wrapped lines
Status: CLOSED WONT_FIX
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 3.4.0
Hardware: All All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on: 20878
Blocks:
  Show dependency tree
 
Reported: 2013-01-07 09:09 UTC by hdu@apache.org
Modified: 2017-05-20 10:14 UTC (History)
4 users (show)

See Also:
Issue Type: TASK
Latest Confirmation in: 3.4.1
Developer Difficulty: ---


Attachments
sample document (21.64 KB, application/vnd.oasis.opendocument.text)
2013-01-07 09:23 UTC, hdu@apache.org
no flags Details
screenshot of the problem (47.40 KB, image/jpeg)
2013-01-07 09:24 UTC, hdu@apache.org
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description hdu@apache.org 2013-01-07 09:09:06 UTC
The trailing space of wrapped lines is underlined since at least AOO 3.4.0 which looks awkward. It also happens in AOO 3.4.1 and in AOO trunk as of today, it didn't happen in the OOo release before or even in OOo 3.4 beta.

This seems to be a Writer only problem, as the change didn't impact components that use the EditEngine.
Comment 1 hdu@apache.org 2013-01-07 09:23:46 UTC
Created attachment 80104 [details]
sample document
Comment 2 hdu@apache.org 2013-01-07 09:24:46 UTC
Created attachment 80105 [details]
screenshot of the problem
Comment 3 hdu@apache.org 2013-01-07 13:40:06 UTC
Oliver-Rainer noticed that the problem is even more general: the complete trailing spaces are displayed and the cursor can iterate over them, which was not the case in the OOo releases. This behavior is easily visible when non-printing characters are enabled. I adjusted the issue summary to this more general problem.

Another important observation is that this happens in both print and web layout and also in print preview.
Comment 4 hdu@apache.org 2013-01-07 14:11:25 UTC
The change was intentionally introduced in issue 20878: "Show spaces at end of a wrapped line in Writer". So the remaining regression is the excessively long underline at line ends.
Comment 5 T. J. Frazier 2013-01-07 22:13:48 UTC
It is not at all clear that this is a problem. The decorated spaces in the screenshot would all be decorated if they fell in the middle of a line. The purposes of line decoration are such that the end-of-line spaces should be shown as they now are, to demonstrate that they exist and are included.
Comment 6 hdu@apache.org 2013-01-10 14:11:52 UTC
Ok, now we know the behavior change was intended (directly or indirectly). Adjusting the issue resolution to RESOLVED. If in the future there should be consensus that the behavior change is not desirable this issue can be reopened.