Issue 121666 - Formletter with textfile as datasource duplicates records if recordcount exceed 40 rows
Summary: Formletter with textfile as datasource duplicates records if recordcount exce...
Status: CLOSED DUPLICATE of issue 123454
Alias: None
Product: Writer
Classification: Application
Component: printing (show other issues)
Version: 3.4.1
Hardware: PC Linux, all
: P3 Major (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-24 11:50 UTC by mh
Modified: 2017-05-20 10:12 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
example text file that can be used to reproduce the given behaviour (205 bytes, text/plain)
2013-01-24 11:53 UTC, mh
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mh 2013-01-24 11:50:07 UTC
testet with aoo 3.4.1 linux & winXP

We produce our formletters by exporting the address data to comma separated textfiles to use as datasource within the writer application.
As soon as the row count exceed the number of 40 records, the application adds 30 records on top. this is fix, e.g. when the recordcount equals 45 the result is 75, for a recordcount of 120 the result will be 150...
To reproduce this behaviour you have to select a textfile with more than 40 rows as dataset in a formletter, go to print and confirm the question to print a formletter and jump to the last record in the tableview (small button under the grid...). It will show the number of your records plus 30.
Always the last 30 records will be duplicated.
You can work around this phenomen by refreshing the dataset before printing or clicking the "last-record-button", but if the user forget do do so, it will print 30 duplicates all time.
Comment 1 mh 2013-01-24 11:53:31 UTC
Created attachment 80164 [details]
example text file that can be used to reproduce the given behaviour
Comment 2 td 2013-02-25 13:17:22 UTC
same here - pls fix it!
Comment 3 Edwin Sharp 2014-03-31 11:55:07 UTC
Duplicate bug

*** This issue has been marked as a duplicate of issue 123454 ***