Issue 121825 - Wrong Thousand Separator and Decimal Separator in locale settings in Peru
Wrong Thousand Separator and Decimal Separator in locale settings in Peru
Status: RESOLVED FIXED
Product: Internationalization
Classification: Code
Component: i18npool
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Ariel Constenla-Haile
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-25 15:57 UTC by neosergio
Modified: 2013-03-16 11:08 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
change the decimal for a period instead of a coma for decimal separator, as well as coma instead of period of thousand separator (476 bytes, patch)
2013-02-25 16:18 UTC, JZA
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description neosergio 2013-02-25 15:57:20 UTC
Wrong separator por thousands and decimal, it must be comma for thousand separator and dot for decimal separator like Mexican locale settings
Comment 1 JZA 2013-02-25 16:02:54 UTC
Will fix now.
Comment 2 JZA 2013-02-25 16:18:11 UTC
Created attachment 80359 [details]
change the decimal for a period instead of a coma for decimal separator, as well as coma instead of period of thousand separator

change the decimal for a period instead of a coma for decimal separator, as well as coma instead of period of thousand separator
Comment 3 Ariel Constenla-Haile 2013-03-03 12:46:03 UTC
(In reply to comment #2)
> Created attachment 80359 [details]
> change the decimal for a period instead of a coma for decimal separator, as
> well as coma instead of period of thousand separator
> 
> change the decimal for a period instead of a coma for decimal separator, as
> well as coma instead of period of thousand separator

This breaks the build.
If you change the decimal and thousand separator you have to change the number format, too:

<FormatElement msgid="FixedFormatskey5" default="false" type="medium" usage="FIXED_NUMBER"  formatindex="4">
<FormatCode>#.##0,00</FormatCode>
<DefaultName></DefaultName>
</FormatElement>

the format code #.##0,00 has point as ThousandSeparator and
comma as DecimalSeparator, while

> > +<ThousandSeparator>,</ThousandSeparator>
> > +<DecimalSeparator>.</DecimalSeparator>
Comment 4 Ariel Constenla-Haile 2013-03-03 12:49:33 UTC
(In reply to comment #0)
> Wrong separator por thousands and decimal, it must be comma for thousand
> separator and dot for decimal separator like Mexican locale settings

The Mexican locale references the Dominican Republic locale, in LC_CTYPE; in LC_FORMAT it should do the same (replacing the currency) so that it takes its number formats.

@neosergio: I'll commit this fix, so that people can build. Please try on a nightly build if all locale setting are as expected.
Comment 5 SVN Robot 2013-03-03 12:53:04 UTC
"arielch" committed SVN revision 1452033 into trunk:
i121825 - Fix build breaker
Comment 6 neosergio 2013-03-04 18:11:32 UTC
@Ariel Constenla-Haile
Thanks for this fix.
Comment 7 Ariel Constenla-Haile 2013-03-04 18:29:48 UTC
(In reply to comment #6)
> @Ariel Constenla-Haile
> Thanks for this fix.

You're welcome.
Could you verify with a build from the build bot? They are located at http://ci.apache.org/projects/openoffice/
In the "Revision" column, make sure the number is equal or greater than 1452033
Today you'll find Windows, and Linux 32/64 bit build (Result = green).
Comment 8 neosergio 2013-03-04 19:00:08 UTC
@Ariel Constenla-Haile
I just test the fix with the build 1452047, and it works.

Best Regards
Comment 9 PAR 2013-03-12 05:16:09 UTC
Hi Andrea please send me the attachment that has to be fix, i am not techincian but a friend can look at it.
Comment 10 Andrea Pescetti 2013-03-12 23:37:21 UTC
Hi Paola, it is not an attachment but a configuration that we can fix from a technical point of view, but that we need confirmation for.

The issue is:
- Can you confirm that when writing the number 12345678 according to the Peruvian habits it is more natural to write 12,345,678 (comma) rather than 12.345.678 (dot)?
- Can you confirm that when writing the number 1.2345678 according to the Peruvian habits it is more natural to write 1.2345678 (dot) rather than 1,2345678 (comma)?
Comment 11 PAR 2013-03-14 01:22:54 UTC
Andrea:

Please check my friend just send me the confirmation:

In Peru you write: 123 456.78

If it doesn't work let me know to tell her.


Paola




se escribe asi 123 456.78
de esa manera en en peru
prueba sino me avisas estre en line
Comment 12 Andrea Pescetti 2013-03-16 11:07:24 UTC
Thank you for the confirmation. So the decimal point bugfix is actually right and it will appear in OpenOffice 4.0.
Comment 13 Andrea Pescetti 2013-03-16 11:08:25 UTC
Setting FIXED as per discussion above.