Issue 121896 - Default configuration concerning MS compatibility should allow to edit Math type formula
Summary: Default configuration concerning MS compatibility should allow to edit Math t...
Alias: None
Product: Math
Classification: Application
Component: ui (show other issues)
Version: 4.0.0-dev
Hardware: PC Windows, all
: P3 Minor (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2013-03-14 11:41 UTC by Andrzej
Modified: 2013-05-13 04:53 UTC (History)
3 users (show)

See Also:
Latest Confirmation in: ---
Developer Difficulty: ---

Can't edit in math formula insert in calc (8.00 KB, application/
2013-03-14 11:41 UTC, Andrzej
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Andrzej 2013-03-14 11:41:06 UTC
Created attachment 80404 [details]
Can't edit in math formula insert in calc

Can't edit in math formula insert in calc.
Problem is in AOO 3.4.1, AOO400-dev.
Comment 1 Rainer Bielefeld 2013-05-01 11:59:16 UTC
NOT reproducible with server installation of  "AOOo 4.0.0-Dev – English UI / German locale [AOO400m1(Build:9700) - Rev.1476029]" on WIN7 Home Premium (64bit)", own separate user profile and installed MatType 6.9

Probably user error (see comments below), so closed INVALID for now.

Thank you for your report – unfortunately important information we will 
need to reproduce your problem is missing.

If you want to reopen this issue because my hints did not solve your problem please add all information requested in following:
- MathType installed with what version?
- Extension texmaths installed (might be useful for you if you often have to
  work with documents containing non-AOOo formula OLE objects
- Write a meaningful Summary describing exactly what the problem is
- Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  (similar to example in Bug 43431)
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected 
  -- concerning your Operating System (Language)
  -- concerning your AOOo version (with Build/revision ID if it's not a public
     and localization (UI language, Locale setting)
  -- Whether that worked in former OOO / AOOo Verions
Comment 2 Andrzej 2013-05-01 13:10:55 UTC
Download attachment -"formula-cant editing in math.xls"
1. Open this file in LibreOffice and double click on formula- You see that you can edit formula. Close file.
2. Now open this file in AOO and double click on formula- You see that you can't edit formula.
This formula be created in MS Office and save as xls. This file i have from my friend.
Comment 3 Rainer Bielefeld 2013-05-01 14:31:04 UTC
@Andrzej (In reply to comment #2):
Hm, that MIGHT show that there IS a problem with AOOo, I did some additional research.

Reproducible with server installation of  "AOOo 4.0.0-Dev – English UI / German locale [AOO400m1(Build:9700) - Rev.1476029]" on WIN7 Home Premium (64bit)", own separate user profile and uninstalled MathType:

1. Open reporter's sample document from File menu of AOOo Start Center
2. Double click Formula Object
   > Object will appear in AOOo Math Window 
   Expected: can be edited
   Actual: Read only

Already reproducible with OOo 3.1.1, OOo 1.1.5, so it seems that never worked with OOo.

In an unzipped ods (sample document saved from LibO) I see a "Star Math 5.0 formula" object, but may be that's a rating by LibO? I am not sure concerning the object type, and AOOo will edit the formula in the LibO.ods without problems

Works fine (object can be edited without MatType 6.9 installed) with 
* "Lotus Symphony Release 3.0.1 Revision 20120110.2000"
* LibO all versions I tested (3.3.0 ... Master 4.1)

Because of the easy workaround with MathType I con't consider this one very urgent. But if other software can do, AOOo should be able, too?

Need to know
What type of object is that?
Can the problem also be solved with an existing extension?
Comment 4 Regina Henschel 2013-05-01 15:16:46 UTC
I cannot confirm it with AOO400m1(Build:9700)  -  Rev. 1476029; Windows 7, 32 bit.

I have tried all four combination of load compatibility settings "MathType to OpenOffice Math" and "Excel to OpenOffice Calc". I could edit the formula in Math if converted, or in MathType, if not converted. No problems at all.

Only the background is the old blue8, because the formula does not come from an old ODF-format but from an Excel format.

I have got a light MathType version from an expired MathType test. It can edit Microsoft Equations 3.0.
Comment 5 Rainer Bielefeld 2013-05-01 16:08:24 UTC
Regina damned, you caught me! Indeed, that's absolutely no problem with appropriate compatibility settings (I simply checked all), AOOo can edit the Math object without MathType installed in the normal AOOo Formula Editor.
I never in my life thought about these settings. It seems that LibO always does some useful settings there and (A)OOo does not?

I checked menu 'Tools -> Options -> Load/Save -> MSO' with a blank new user profile for 
* LibO 4.1 Master: All check boxes checked
* AOOo 4-Dev:      NONE of the check boxes checked.

This MIGHT be not a good idea, users become worried as we see here. But on the other hand, I haven't a clue what will happen when the document will be saved as an .xls again after an edit. May be the MS-OFFICE version with what the document has been created will no longer be able to edit the document? I have no experience here. 

But it seems clear that the only remaining issue is this configuration issue.
I never checked how that is with AOOo for Linux
Comment 6 Andrzej 2013-05-01 17:30:03 UTC
Tools-->option-->Load/Save-->Microsoft Office--> in "MathType to OpenOffice Math or reverse" mark [L] and [S].
Now I can edit formula. 

Why in AOO is not default setting?
Comment 7 Rainer Bielefeld 2013-05-13 04:53:04 UTC
CONFIRMED for now because I currently can't imagine that many users will desire these options inactive by default.